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C H A P T E R  1
Introduction to the Solaris 8 Desktop



Objectives

The purpose of this module is to provide the learner with an
understanding of their account and available window
environments, and to become familiar with the CDE desktop.

Upon completion of this module, the student will be able to:

  Log in and out of an account.

  Change system password.

  Change window environments.

  Use the mouse.

  Access the CDE Front Panel, subpanels and applications.

  Activate window focus.

  Move and resize windows.

  Minimize, restore and maximize windows and icons.

  Use the Window menu.

  Use the CDE Lock control.



Getting Started

____________________
Your Account

The combination of a user name and home directory (login
directory) constitutes an account.

  Your user name (login ID) identifies you to the system.

  You can choose your user name, but it must be added to the
     system by your system administrator.

  A home directory is created at the same time by the system
     administer

  Your home directory is an area in the file system reserved
     for your use and control.

____________________
Your Password

Your password allows you to secure your account from
unauthorized access. You are the only one who should know your
password. See the section on changing your password in this
module.

___________________
Your Host Name

The host name, also called machine name, system name, or
workstation name, is the name given to your workstation. It 
usually appears before your login prompt.

Example:

traffic12 login:  traff12

In the example, "traffic12" is the host name, and "traff12"
is the user name.



Changing Your Password

_____________________
Using the passwd Command

The passwd command changes or installs a password associated
with your user ID.

When changing a password, passwd prompts you for the old
password and then for the new one. You must supply both and the
new password must be typed twice to prevent mistakes.

Effective passwords keep the computers and network secure.
The most common way of breaking into a UNIX-based network
like Sun's is by guessing passwords. Your proper choice and use
of passwords discourage break-in attempts and make guessing
much more difficult.

Select a good password

       Use at least six characters - preferably eight

       Combine letters (upper and lower case) with numbers / 
          symbols so your password is easy to remember, yet 
          difficult to crack. Some examples are: Hope2Day, Crazy4U, 
                    We_Rela8.

      Avoid anything that someone might guess you would use: 
         common words, your name or nickname, birth date, social 
         security number, pet's name, login name, any of the previous
         spelled backward, "popular" names such as "garfield" and 
         "simpsons", and even common profanity.

      Never reveal your password to anyone and never write it 
         down where others can see it.

      Change your password periodically (about every six months).



Example:

prompt%  passwd <Return>
passwd:  Changing password for traffic12
Old password: invisible old password  <Return>
New password: invisible new password <Return>
Retype new password: invisible new password <Return>
prompt%
       



Window Environments

The Common Desktop Environment (CDE) is the current window
environment running on Sun workstations.

 Figure 1-1 CDE Login Screen

The Login Screen indicates which desktops you can select: the
CDE desktop or OpenWindows. The OpenWindows environment
is being phased out. Refer to the section on logging in within this
module.

The CDE Front Panel, shown below, provides controls for starting
applications, indicators, and subpanels (menus). Using the Front
Panel is covered in this module.
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(if installed) Personal Printers
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Figure 1-2 CDE Front Panel



Logging In and Out

_____________________
Logging In

Logging in identifies you as a valid user and gives you access to
your account on the system. The default CDE login screen
welcomes you to start a standard CDE session or to choose from a
menu of login options.

  Starting a Standard CDE Session

      1. In the CDE login screen, enter your login in the user name
          text box, and click OK.

      2. Enter your password in the subsequent window then click
          OK. If you make a mistake. Click the Start Over button to
          refresh the screen and remove any typed entry.
          

      3. If the following window appears, choose the CDE
          environment and then click OK. (Note: Your system
          administrator may have already done this for you.)

 Figure 1-3 Preliminary dialog box



Note: As the default, you will see File Manager and Help Viewer
start on your screen. If you quit these tools and exit your current
session, these tools will not start up again the next time you log in
to a CDE session.

_____________________
Logging Out and Lockscreen

Most users do not need to log out of their system each time
they are finished with their work session.

Logging out is not required if:

  You are the only user on the workstations

  You have a standalone workstation and are not on the
     network.

If you are sharing a system and other people log in to your
computer under their own accounts, users should log out after
each work session.

Logging out is required if:

  Multiple users share a workstations

  Service will take place and you have received a notice to
     log out.

  Logging out

     The Exit button on the Front Panel is used to log out from the
     CDE session.

    Exit control

     1. Be sure to save all work in open application windows in
 each workspace.

     2. Click the Exit control on the Front Panel, or choose Log out
         from the Workspace menu.

         By default, you will be asked to confirm that you want to
         log out.

     3. Click OK or press Return to confirm log out.



     Note: The current CDE session will be saved so that you can 
     return to the same workspace windows when you next log in
     to a CDE session. You must however, remember to save all 
     data in the open applications, as it will be lost when exiting
     from your CDE session.

     Refer to Help Manager and Style Manager in the CDE User's
     Guide or on-line Help for more information on changing the
     default activities of the Exit button so that no confirmation is
     required.

  Locking the Display
Lock control

     As exiting (logging out) from the desktop is not always
     required, the easiest way to prevent unauthorized use of your
     system when you are away form it is to lock the display (turn
     on lockscreen)

     1. To lock your display, click the Lock control in the Front
         Panel.

     2. To unlock your screen, type your password.



Using the Mouse

Mouse buttons are used to control objects on the workspace and in
windows by moving the pointer and pressing and releasing the
different mouse buttons. Each button serves a different purpose.

_____________________
Mouse Buttons Identified

Mouse button 1. This button is used to select text, open icons,
push buttons in panels and dialog boxes, etc.

Mouse button 2. This button extends or adjusts selections and is
customizable.

Mouse button 3. This button pops up various menus depending
upon where the mouse pointer is when the button is pressed.

Mouse button 2

     Mouse button 1 Mouse button 3

 Figure 1-4 Mouse buttons identified



_____________________
Mouse Button Terminology

The terminology used to describe actions performed with the
mouse are as follows.

Press or Hold. Hold down the mouse button.

Release. After depressing a mouse button, release it to initiate the
mouse button.

Double-click. Click twice quickly on the same mouse button
without moving the mouse.

Move. Move the pointer to another area on the screen without
using any mouse buttons.

Drag. Point to an object, press mouse button 1, hold it down as
you move the object to its destination with the pointer, and release
the button.



Working in the CDE Environment

_____________________
Introduction to CDE

The Solaris Common Desktop Environment (CDE) is an
interface that provides a consistent look and feel across UNIX
environments. SunSoft Inc., Hewlett-Packard, IBM
Corporation, and Novell Inc. each contributed to establish a new
standard for user and application interfaces based on the X
Window System and Motif.

The CDE environment consists of:

      Login Manager - A window for logging into the
         desktop. Available automatically after your workstation
         is booted.

      Session Manager - A service for launching your
         applications on the desktop at login, and "remembers"
         their state when you log out.

      Window Manager - A service that controls CDE
         application windows, and provides the Front Panel for
         launching CDE applications.



_____________________
Using the Front Panel

The Front Panel window appears at the bottom of the desktop. It
provides controls for starting applications, indicators, and
subpanels (menus) you use in your everyday work.

The Front Panel also provides the workspace switch for selecting a
workspace. Arrow buttons over the Front Panel controls identify
subpanels.

In this module, you will learn how to use the following CDE
tools:

     File Manager

     Text Editor

     Desktop Controls

     Online Help

StarOffice                    Applications
subpanel                       subpanel
(if installed) Personal Printers

      subpanel          System
                 subpanel

                  Browser                                         Workspace             Printer               Help
                  subpanel                Mailer                 switch                                        subpanel

      Netscape            File             Front Panel                         Exit       Desktop      Help
      subpanel          Manager             Lock                                               Tools               Trash
      (if installed)    can

          Calendar
          subpanel



_____________________
Starting Applications

In CDE, there are several ways to start applications.

      Click the Front Panel Control

      Type a command in a Terminal window, accessed from the
         Text Editor subpanel

      Use the Workspace menu

      Use Application Manager

_____________________
Using the Workspace Menu

To access the Workspace menu, click mouse button 3 on the
workspace backdrop (background).

The Workspace menu includes:

Programs Menu of tools such as Mailer,
Terminal, Calendar, etc.

Shuffle Up Brings the bottom window forward

Shuffle Down Puts the top window in the
background

Refresh Redraws the display

Minimize/Restore Front Panel Turns the Front Panel into an icon or
opens it form the icon

Restart Workspace Manager Stops then restarts the Workspace
Manager (typically after you have
customized configuration files)

Log out Same as Front Panel Exit control



_____________________
Using a Terminal Window

The Terminal window is used to access a prompt for entering
UNIX commands.

  To start a Terminal Window

     1. With mouse button 3, click on the desktop background and
         from the pop-up menu choose Tools.

     2. Click on Terminal in the Tools submenu.

     3. Enter commands at the prompt.



Using Keyboard Accelerators

            Figure 1-5 Keyboard Accelerator keys

The left Function Keys on your keyboard are labeled.

The Front key brings the window at the pointer location to the
front of the screen. When the window is already at the front, it is
moved to the back of the screen. If there are no overlapping
windows, there is no change.

The Open key opens the icon at the pointer location, or closes the
window at the pointer location.

The Help key opens a help window at the pointer location.

The Cut, Copy, Paste, Again and Undo accelerator keys are
particularly helpful when working in a Text Editor window and
Compose window in Mailer.

Help

Stop Again

Props Undo

Front Copy

Open Paste

Find Cut



Advantages/Disadvantages - CDE Desktop

_____________________
Advantages

      Standardizes the look and feel of the UNIX desktop
         regardless of the manufacturer.

      Integrated with other tools and applications such as
        OpenWindows Snapshot and StarOffice.

      Use standard keyboard accelerators within the majority of
         CDE applications.

      Do not need to know UNIX commands to create, move,
         and copy files and folders.

      Use drag and drop for many actions.

      Multiple workspaces permit better organization of your
         tools, applications and projects.

_____________________
Disadvantages

     Learning curve to become familiar with all the tools and
        applications.

      Using CDE controls and subpanels is slower to move files
         and change directories as compared to typing UNIX
         commands in a Terminal window.



What You Should Have Learned

Upon completion of this module and lab, the student should have
learned:

      How to log in and out of an account.

      How to change system password.

      How to change window environments.

      How to use the mouse.

      How to access the CDE Front Panel, subpanels and
         applications.

      How to activate window focus.

      How to move and resize windows.

      How to minimize, restore and maximize windows and
         icons.

      How to use the Window menu.

      How to use the CDE Lock control.
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Introduction to the Solaris 8 Desktop



Lab Overview

This lab introduces the skills you must know when using the CDE
Window system. A section on CDE Terminology for this module
is included. Review questions follow the lab.

_________________
Basic User Skills

       Starting a standard CDE session
       Moving, minimizing and opening the Front Panel
       Activating controls and using subpanels
       Activating window focus
       Moving and resizing windows
       Minimizing, restoring and maximizing window and icons
       Using the Window menu, and closing a window
       Scrolling in a window
       Bringing a window or icon forward
       Locking the display

__________________
Intermediate User Skills

       Using tear-off menus
       Changing, adding, deleting and renaming workspaces
       Placing windows in a workspace
       Using on-line Help

___________________
Advanced User Skills

       Starting applications from the Workspace menu
       Starting applications from a Terminal window
       Customizing the desktop, login and the Front Panel
       Remote login to your regular workstation



Basic User Skills

In this section of the lab, you'll login and work with CDE 
windows, controls and the Front Panel.

___________________
Preliminary Steps

  Starting a standard CDE session

     1. In the CDE login screen, enter your login in the user name
         text box, and click OK.

     2. Enter your password in the subsequent window then click
         OK. If you make a mistake, click the Start Over button to
         refresh the screen and remove any typed entry.

     3. If the following window appears, choose the Common
         Desktop Environment (CDE) and then click OK. (Note:
         Your system administrator may have already done so for
         you.)

    
    

Note: As the default, you will see File Manager and Help Viewer
start on your screen. If you quit these tools and exit, the next time
you log into a CDE session, these tools will not start up again.



____________________
Using the CDE Front Panel

The two main elements of the Front Panel are the Main Panel and
the subpanels indicated by an arrow button. The Quick Reference
Card can also help you identify Front Panel controls. In the
exercises below, you'll learn the basic skills for working with
Front Panel controls.

  Moving, minimizing and opening the Front Panel

     1. To move the Front Panel, with mouse button 1 click and
 Minimize button           hold on the move handles located at each end of the Front
           Panel and drag to a different location on the desktop.

     2. To minimize the Front Panel (close to an icon state), click
          the minimize button (small round dot) in the upper right
          corner of the Front Panel.

          The icon is labeled with the workspace name.

    Move handle      3. To open the Front Panel window icon, with mouse button 1, 
          double-click on the icon.

  Activating controls and using subpanels

     1. To activate the Calendar control, click with mouse button 1 
         on the Front Panel Calendar control.

   Arrow Button       2. To open the File Manager subpanel, with mouse button 1,    
          click the arrow button above the control.

          The subpanel (menu) slides up. A little later in the lab
          you'll learn how to add and remove desktop tools to the
          subpanel.

      3. To move a subpanel, click and hold with mouse button 1 
          on the title bar and drag , just like other windows.

       4. To close a subpanel, click with mouse button 1 on the  
           Window button  in the upper left corner of the subpanel 

         Window menu button            and select Close.

               Note: You may also click the Arrow button above the control 
       to close a subpanel.



The subpanel closes automatically when you choose a
control unless you have moved the subpanel from its
original location.

        5. Use the Window button in Calendar to close the window.

You may also double-click on the Window menu button 
located in the upper left corner of the window with mouse

 button 1 to close a window or menu.

____________________
Working with Windows and Icons

In the exercises below, you'll learn how to open, close and
manipulate windows and icons, and use the Window menu. You'll
be using the File Manager and Text Editor.

  Activating window focus

File Manager      1. Click the File Manager control to open a File Manager 
control          window.

        2. Click the arrow above the Text Note control to access the
            subpanel.

     3. Choose Text Editor from the subpanel to open the Text
Text Editor             Editor window.
control

     4. To make a window active, click with mouse button 1.

         When selected, the cursor blinks, the window frame changes
         color and the window accepts input from your mouse or
         keyboard.

  Moving and resizing windows

    1. To move the Text Editor window, drag its title bar.

    2. To resize the Text Editor window, drag its resize corner or
        border.

      Resize corner



  Minimizing, restoring and maximizing windows and
    icons

    1. To change the Text Editor window to an icon state.
        (minimize), click the minimize button in the upper right
        corner of the window.

            Minimize button
    2. To open (restore) the icon, double-click the icon.

    3. To maximize the Text Editor window, click the maximize
Maximize button         button in the upper right corner of the window to display

        the window in its largest allowable size.

    4. Return the window to its former size by clicking the
        maximize button again.

  Using the Window menu, and closing a window

    1. To access the Window menu, click the Window menu
        Window menu button             button (small rectangle) in the upper left corner of the Text

        Editor window.

        You may also use mouse button 3 on the window header
        bar to access the Window menu.

    2. To close the Text Editor window, choose Close from the
        Window menu button.

  Scrolling in a window

    Many windows include a "scrolling list." Information is
    provided below for scrolling in a window. There are no lab
    steps.

  To move up or down one line, click the appropriate
     arrow.

Arrow
  Click above or below the rectangular slider to move up

     or down one screen.
Slider

  Drag the slider to move to a region of the window.



  Bringing a window or icon forward

    1. Open another Text Editor window.

    2. Click a visible part of the Text Editor window's frame, (or
        anywhere on an icon) to bring a window or icon to the 
        front of other windows. You may also:

     Use the Front key - usually located on the left side of
    your keyboard.

   Bring a concealed window or icon to the foreground
     by choosing Shuffle Up from the Workspace menu
     which is discussed in the Intermediate User Skills
     section of this lab.

    3. To send a window to the back of other windows, choose
        Lower from the Window menu button.

___________________
Using the CDE Lock Control

To prevent unauthorized use of your system when you are away
from it, you may want to "lock the display" (turn on lockscreen).

  Locking the display
     Lock control

    1. To lock your display, click the Lock control in the Front
        Panel.

    2. To unlock your screen, type your password and press
        Enter.

Please continue to the Intermediate User Skills section of this lab.



Intermediate User Skills

In this section of the lab, you'll work with tear-off menus,
multiple workspaces, and on-line Help.

_____________________
Using Tear-off Menus

The menus of some CDE tools may be kept anywhere on your
desktop. In this exercise, you'll use a tear-off menu from the
Calendar window.

          Tear-off menu

  Using tear-off menus

    1. Start a Calendar if one is not already on your desktop.

    2. Click View to bring up the menu.

    3. Click the dotted line at the top of the menu.

        The menu stays on the desktop for continued use until
        such time as you decide to remove it from the desktop.

    4. The menu may be closed by clicking the Window button in 
        the upper left corner of the window.

_____________________
Using Multiple Workspaces

Workspaces in CDE are like separate screens of windows that help
you organize your work. A workspace named Reports could
contain the tools you use to prepare reports, such as a spreadsheet,
desktop publishing applications, and a graphics package. In the
exercise below, you'll change workspaces, add a window to a 
workspace, and rename the workspace.



  Changing and renaming workspaces

     1. Open the Calendar tool if one is not already on your
         desktop.

         In a moment, you'll put the Calendar tool in more than one 
         workspace.

     2. To display another workspace, click the workspace's
         button in the Front Panel - for example, workspace Two.

 Workspace Two      3. To rename this workspace, click the same workspace 
         Front Panel button (workspace Two) with mouse button 3 
         and select Rename from the menu.

     4. Type your first name in the text field and press Return.

           Thus far, you have the Calendar tool in workspace One.
           Now, let's put the window in workspace Three.

  Placing windows in a workspace

    1. Return to the original workspace where Calendar is on the
        desktop.

             Window menu button
    2. In the open Calendar window, from the Window menu,
        choose Occupy Workspace and select one or more
        workspaces from the dialog box.

        Note: Hold down Shift while you select multiple contiguous
        workstation names, or hold down Control to select multiple
        discontiguous names.

    3. Click OK in the dialog box.

    4. Change to the various workspaces to see the Calendar tool
          in each workspace.

  Removing a workspace

     1. Point to the workspace button with your name (the
         workspace you want to remove).

     2. Press mouse button 3 and choose Delete from the control's
         pop-up menu.
          If you remove a workspace that contains windows, those
          windows are not moved to another workspace.



  Adding a workspace

    1. Press mouse button 3 in the workspace area, and choose
        Add Workspace from the menu.

    2. Rename the workspace.

    3. In the main workspace you have been working in, close
        the Text Editor and Terminal windows. It is not necessary
        to save the file.

_____________________
Referencing On-line Help

Help Manager is a special help volume that lists all the on-line
Help registered on your system. In the exercise below, you'll learn
how to access Help Manager, choose a topic from the topic tree,
navigate Help, and print a Help topic.

  Opening, browsing, and navigating Help

  Help Manager     1. To open Help Manager, click the Help control on the Front
   control         Panel to display the top level of Help Manager.

        The Welcome to Help Manager screen appears. The topic
        tree is shown in the top portion of the Help window.

    2. Choose Overview and Basic Desktop Skills to browse this
        topic.

    3. Select the topic Introducing the Desktop Skills to browse
        this topic

    4. Select the topic How to Get Help.

        In the dialog box under the topic Getting Help, you will
        see topics: Help Key, Help Menu and Help Button.

    5. Select one of the topics. The display area in the bottom
  portion of the Help window changes according to the topic 
  selected.

    6. Select a topic in the bottom portion of the display.

    7. Now use the Backtrack, History, and Top Level buttons to
        move between Help topics.



  Printing Help topics

     1. To print a Help topic, from the File menu, choose Print to
         display the dialog box.

     2. In the Printer text area, type the name of the printer.

     3. Select Current Topic, and click Print.

     4. For now, use the Window menu button in the main
         window to close the Help Viewer.

In the exercise below, you'll learn how to access help for working
with the Front Panel subpanels and controls by using Front Panel
Help and On Item Help.

  Accessing Help from the Front Panel

     1. Click the arrow above the Help control to pop-up the 
         subpanel.

     2. Drag it to the side of the desktop.

     3. Choose Desktop Introduction from the subpanel.

     4. Choose Glossary to view the on-line CDE glossary.

         Now let's use the On Item Help feature.

     5. To get On Item Help on a Front Panel control, choose On
         Item Help on the Help Manager control subpanel.

           Help Subpanel      6. Move the question mark pointer to the control for which
         you want help - for example, the lock control, and click
         mouse button 1.

     7. WAIT for the Help window to appear with a description of 
         the Front Panel Lock control.

     8. For now, close all the Help windows.

Most applications, including Help Manager, have a Help menu for
requesting specific kinds of help. In this next exercise, you'll learn
about the Help menu while working in a Terminal window.



  Accessing and using an application's Help menu
 Help
 menu      1. Open a Calendar window if one is not already open on

          your desktop.

     2. Click the Help menu item in the upper right corner of the
         window. Standard menu items and application-specific
         menu items appear on the menu.

     3. Choose Overview to display introductory information
         about the application and WAIT for the window to open.

     4. In the Calendar window, from the Help menu, choose
         Tasks to display instructions for using the application.

         Other Calendar Help menu items include:

  Choose Reference to display summary information
     about application components.

  To use On Item help within the application, choose
     On Item from the menu, and click the question mark
      pointer on an icon on the toolbar to display the
      description.

  The Using Help menu item displays information
     about using Help.

  The About Calendar menu item displays version and
     copyright information about the application.

     5. Close the Help subpanel, Help and Calendar windows.

     Please continue to the Advanced User Skills section of this
     lab.



Advanced User Skills

In this section of the lab, you'll start applications from other than
the Front Panel, customize the desktop, login and Front Panel.

_____________________
Starting Applications

In the exercise below, you'll learn other ways to start desktop
applications other than from the Main Panel or subpanels.

  Starting applications from the Workspace menu

     1. To start applications from the Workspace menu, press and
          hold mouse button 3 anywhere in the workspace to pop-
          up the menu.

     2. Choose Tools and an application from the submenu-
         for example, Terminal.

  Starting applications from a Terminal window

     1. To start applications from  a Terminal window, enter the
         command at the prompt-for example, to start the Netscape
         application, type:

          netscape& <Return>

     2. Close the Netscape application and Terminal windows.

 



____________________
Customizing the Desktop

In CDE, Style Manager is used to customize the desktop. In this
exercise, you'll use the Window, Backdrop, and Font controls.

     1. To access these controls, start Desktop Controls from the
         Front Panel.

  Changing window behavior

     1. Double click on Window Style Manager to open the 
         Window control. This action will also open a Style Manager 

         window providing access to the same controls.

     2. Choose Point In Window To Make Active.

         This option will make the window active when the mouse
         pointer is in the window.

     3. Click OK.

     4. In the subsequent dialog box, click OK.

     5. Click Exit on the Front Panel to log out.

     6. Type your password to log back in.

     7. Now move the mouse pointer to a Terminal window to see
         that it is no longer necessary to click in the window to 
         make it active.

  Changing screen backdrop (background)

     1. To change the backdrop pattern of a workspace, click on 
         Backdrop in the Style Manager window to open the 

         Backdrop control.

     2. Choose a backdrop from the scrolling list and click OK.
         The change is effective immediately.



  Customizing fonts for new windows.

     1. To change font size and font group for titles, menu bars,
         window labels, and text, click on Font in the Style Manager 

         window to open the Font control.

     2. Click 4 in the scrolling list, then click OK.

     3. In the subsequent Notice dialog box, click OK.

     4. Start a new Terminal window and look at the difference in 
         the point size of the text.

 ____________________
Customizing Login

Whenever you are logged into the desktop, you are working in a
current session. By default, when you log out, the desktop saves
your current session and restores it the next time you log in.

You can also save a home session, a session you want to be able to
return to regardless of what you do during the current session.

In this exercise, you'll customize your login.

  Changing how your next session starts

     1. To change how your next session starts, click to open the
         Startup control, select the settings you want, and click OK.

     Note: To define a new home session based on your current
     session, select Set Home Session.

          If you have never set a home session, the system default
          session is used when you select Return to Home session.
          Choose the Ask Me at Logout setting if you want to decide
          what your next session will be at logout time.

     2. Close the Style Manager window.

     Note: If the Command Line Login option is chosen, you must
     press the Return key within ten seconds of making the choice,
     otherwise the CDE login screen will restart.

 



Customizing the Front Panel

In this exercise, you'll put a subpanel control in the Front Panel,
add an OpenWindows application to a subpanel, plus add and
remove subpanels.

  Placing a subpanel control in the Front Panel

     1. Click the arrow to open the Text Note subpanel-
         Applications.

     2. Point (don't click) to the Text Editor subpanel control.

     3. Press mouse button 3 and choose Promote to Front Panel
         from the control's pop-up menu.

        The Text Editor control appears on the Front Panel.

     Note: Controls are never deleted from the Front Panel.
     Simply repeat the above procedure to replace one control with
     another control.

     4. Keep the Applications subpanel on your desktop

         Next, you'll use Application Manager which is a container
         for applications and other desktop tools - such as
         OpenWindows applications.

  Adding and removing an OpenWindows application 
    on a subpanel

Application      1. Start the Application Manager by placing the pointer on
Manager          Applications and press mouse button 1.
control

          2. In the Application Manger window double-click to open the
         OpenWindows folder.

     3. Drag the OW File Manager to the Install Icon on the
          Applications subpanel.

         The OW File Manager appears on the subpanel.

     4. To delete the OW File Manager from the Application
         subpanel, place the pointer on the icon, press mouse button
         3 and choose Delete from the pop-up menu.



Review Questions
1. What CDE control is used for lockscreen?
    _________________________________________________________
    _________________________________________________________

2. Correctly name the 3 mouse buttons.
    _________________________________________________________
     _________________________________________________________
    _________________________________________________________

3. What CDE control provides access to a command line interface with
    prompt? __________________________________________________

     _________________________________________________________

4. Define Close in CDE terminology.
     _________________________________________________________
     _________________________________________________________

5. How do you discern a "tear-off menu" from other menus?
    _________________________________________________________
    _________________________________________________________

6. When is using multiple workspaces advantageous?
    _________________________________________________________
    _________________________________________________________
    _________________________________________________________

7. Identify the differences between using Help Manager and using the
    Help menu. _______________________________________________
    _________________________________________________________
    _________________________________________________________

8. What is the name of the CDE control used to customize the desktop?

    _________________________________________________________

9. What control is used to customize login?

    _________________________________________________________
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C H A P T E R  2
File Manager



Objectives

The purpose of this module is to introduce the learner to the CDE
tool, File Manager, and the concepts related to maintaining and
organizing files.

Upon completion of this module, the student will be able to:

  Describe directories and files.

   Use file naming conventions.

   Identify file types.

   Identify the home folder.

   Change folders.

   Create files and folders.

   Move and copy files and folders.

   Delete files and folders to the Trash Can.



About the File Manager

File Manager provides you with a graphical display of the UNIX
file system. You can use it to find, copy, move, open, close,
delete, undelete and print files

The File Manager displays icons that represent directories, data
files and applications. You can select and operate on these icons
within the File Manager either by dragging and dropping, or
using cut, copy and paste. In addition, you can reorganize your file
system by moving or copying files between folders, create new
files and print existing files. File Manager may also be used to link
files and transfer files to other machines.

Icons representing folders may be dragged out of the File Manager
window onto the desktop for easy drag and drop between folders.
Files and folders may be dragged directly to the Trash Can control
on the Front Panel.



Solaris File System

_____________________
Organizing Data

The file system organizes data similar to the way a file cabinet
does, in a hierarchical structure.

  Directories are like file drawers.

  Subdirectories are similar to folders.

  Files are equivalent to the contents of the folders, the
    pieces of paper.

    

        Figure 2-1  Similarity of Solaris file system and file cabinet

Solaris



_____________________
Directory Naming Conventions

     Alpha Characters: A-Z and a-z
        Solaris is a case sensitive operating system. The
        directories memos and Memos are seen as two distinct
        directories by the system.

     Numeric: 0-9

     Special Characters: _, ., %, +, -, =, #, @, ^, : etc.

As a general guideline, users should avoid using special characters
when creating new folder names, because unexpected results
may occur.

Note: It is recommended that only the "_" (underscore) and "."
(period) be used if a special character is desired.

Examples of legal directory names:

        Budget Staff budget.93

        Memo_3 sched.q1 Equip-forecastFinal+

        Equip-forecast Final

Examples of illegal directory names:

        >1987 1987|1988         -Equip-Forecast

        $Forecast Final& Staff* Fsct&Final



_____________________
File Naming Conventions

     Alpha Characters: A-Z and a-z
        Solaris is a case sensitive operating system. The files

        sched.q1 and sched.Q1 are seen as two distinct files by the
        system.

     Numeric: 0-9

     Special Characters: _, ., %, +, -, =, #, @, ^, : etc.

As a general guideline, users should avoid using special characters
and spaces when creating new file names, because unexpected
results may occur.

Note: It is recommended that only the "_" (underscore) and "."
(period) be used if a special character is desired.

Examples of legal file names:

        budget.2090 sched.q1 staff.rpt

        dept.goals Equip-forecastFinal+

Examples of illegal directory names:

        q1<q2 >1987 a_priority?

        $revenue.q4 -action /mgt&staff/

Suffices

       A suffix is included with many file names to help identify the
        type of file. A list of these suffices include:

        .sdc StarOffice spreadsheet .txt ASCII text
        .sdw StarOffice word .ps PostScript
        .sda StarOffice drawing .tar tape archive
        .sdd StarOffice presentation .au audio
        .pdf portable document format
        .Z compressed



_____________________
File Naming Conventions

All files are either executable or non-executable. Executable files
are understood by the system, and non-executable files are
understood by people or an application program.

       Executable Files

      Each executable file is of a specific type. Some of the most
       common are:

  Application Program

  C Program

  Shell Script

       Non-executable Files

       Each non-executable file can contain a different kind of data.
        Some of the most common are:

  ASCII text

  Application Program Specific data

  Audio data

       ASCII Text Files

       ASCII stands for "American Standard Code for Information
        Interchange" (pronounced as'-key). This code was developed
        jointly by equipment manufacturers and users to simplify and
        standardize machine-to-machine and system-to-system
        communications. The common text editors used on a Sun
        workstation to alter or view an ASCII file are "vi" and"Text
        Editor".



       Application Program Specific Files

       Application Program Specific data files are understood by the
        application program which created them. Examples are:

  StarOffice files

  Microsoft Office files

       Raster File

       A raster file is a standard bit-mapped image which can be
        altered and displayed by various Application Programs or
        UNIX commands. A 1-bitplane image can have two colors
        (usually black and white), and an 8-bit plane image can have
        256 colors.

       Audio File

       An audio file is a standard 8-bit audio sample which can be
       heard on a SPARC workstation; and can be created, altered, or
       played using various application programs.



Advantages/Disadvantages - File Manager

_____________________
Advantages

      Integrated with other CDE tools.

      Use standard keyboard accelerators.

      Do not need to know UNIX commands to create, move,
         and copy files and folders.

      Use drag and drop for many actions.

      Use the Trash Can control on the Front Panel for simple
          disposal of unneeded files and folders

      Use multiple windows to simultaneously view the contents
          of different folders which is helpful when copying and
          moving files.

_____________________
Disadvantages

      Cannot view every single file on your system at a glance.

      Cannot drag and drop files and folders on the icon path.

      Using CDE controls and subpanels is slower to move files
          and change directories as compared to typing UNIX
          commands in a Terminal window.



What You Should Have Learned

Upon completion of this module and lab, the student should have
learned:

     How to describe directories and files.

     How to use file naming conventions.

     How to identify file types.

     How to identify the home folder.

     How to change folders.

     How to create files and folders.

     How to move and copy files and folders.

     How to delete files and folders to the Trash Can.



L A B  2
File Manager



Lab Overview

This lab introduces the skills you must know when using the CDE
File Manager. Complete all sections of the lab in order - Basic,
Intermediate and Advanced exercises. Review questions follow
the lab.

_________________
Basic User Skills

       Identifying file types
       Identifying the home folder
       Changing to other folders
       Creating folders and files
       Using drag and drop in File Manager
       Printing a file
       Copying and moving folders and files
       Deleting folders and files
       Using folder and file icons in the workspace

__________________
Intermediate User Skills

       Renaming folders and files
       Setting View options
       Using Selected menu items

___________________
Advanced User Skills

       Linking folders and files
       Finding folders and files



Basic User Skills

In this section of the lab, you'll identify file types, change to other
folders, create and delete files and folders, and use drag and drop.

____________________
Starting File Manager

  Starting File Manager

    1. Click the File Manager control to open the window.

        The window opens automatically to your home directory.
        From that folder, you can move to other folders, both up
        and down in the hierarchy.

____________________
Identifying File Types

  Identifying folders, data files, and executable files

    1. Directories are indicated by icons which look like folders.
        Do you have one or more directories showing on your
        screen?

_________ yes   ________ no

    2. Data files such as documents, graphic files, and spreadsheet
        files are displayed as sheets of paper with lines
        simulating text. Do you have a data file showing in your
        home directory?

_________ yes   ________ no

    3. Application icons are executable files whose icon includes
        a lightening bolt. Do you have an executable file showing
        in your home directory?

_________ yes   ________ no



  Identifying your home folder

    1. Look at the row of folder icons (also called directories)
Iconic path         immediately below the menu items at the top of the File

     Manager window. All of these folder icons represent the
     pathname to your "home" directory (in this example,
     trainer is the "home" directory).

Text path

  Changing to another folder

    1. With mouse button 1, double-click on a folder icon.

        Notice that the folder icon is now located at the end of the
        path, following your home directory.

  Changing to the parent and home folders
   .. go up icon

          1. To change to the parent folder, choose Go Up from the File
        menu, or double-click the ..(go up) icon in the object
        viewing area.

        The parent folder is the folder above the folder in which
        you are currently working.

        You may also click the Folder name in the text path to
        change to a parent or other folder.

    2. To quickly change to the home folder, choose Go Home
        from the File menu.

  Changing to another folder using Go To

    1. From the File menu, choose Go To to open the window.

    2. In the Destination Folder text type the following
        replacing <folder_name> with the name of a folder located
        in your home directory.

~/<folder_name>

    3. Click OK.
        The window disappears and you are changed to the
        correct directory.



____________________
Creating Folders and Files

In this exercise, you'll create folder and files.

  Creating folders and files

    1. From the File menu, choose New Folder.

    2. In the New Folder Name text box, type:

ClassFolder

        The name of this folder begins  with a capital letter to make
        identifying it as a folder easier. Files begin with a lower
        case letter, identifying them as files. UNIX does not
        allow spaces in a file name or directory name. If you need
        to separate two words in the file or directory name, use the
        underscore (_).

    3. Click Apply.

        Repeat steps 1 and 2 to create a folder named Labs and
        click OK.

        Next, let's create a new file named classfile.

    4. From the File Menu, choose New File.

    5. In the New File Name text area type:

classfile

        Notice the standard UNIX naming convention of using
        lowercase letters for naming files is followed.

    6. Click OK.

  Adding text and saving the file

    1. Double-click the icon to open classfile.

        A Text Editor window opens. Notice the name of the file
        appears in the header bar of the window.



    2. With the pointer inside the large white pane of the Text
        Editor window, type:

This document is being created in a Text Editor
window.

    3. From the File menu, choose Save.

    4. From the File menu, choose Close.

    5. Open the same Text Editor file again (classfile) to see
        the text you entered earlier, then close the window.

____________________
Using Drag and Drop in File Manager

You may drag and drop files in File Manager to a subdirectory or
parent folder, to the Printer control on the Front Panel, and to copy
file and folders.

  Drag and drop a file to a subdirectory or parent folder

    1. To drag and drop a file into a subdirectory folder, place the
        mouse pointer on the classfile icon and using mouse 

        button 1, click and hold while you drag the file on top of
        the ClassFolder icon.

    2. Change to the ClassFolder folder by placing the mouse
        pointer on the folder icon and double-clicking mouse
        button 1. You should see that the file has been moved.

 .. go up icon

    3. To move the classfile file to the parent folder, drag
        the icon on top of the ..(go up) icon.

    4. Change to the parent directory to see the file.



  Printing a file

                 Printer control     1. Drag the classfile from the File Manager to the Printer
        control on the Front Panel.

    2. In the Print window, type the classroom printer name in
        the Printer text area.

    3. Click Print. The dialog box disappears.

    Note: With the file selected (highlighted), you may also
    choose Print from the Selected menu in File Manager.

  Copying  folders and files

    Using the Control key when you drag and drop copies a file.

    1. Press the Control key, then drag the classfile icon to
        the ClassFolder icon.

    Note: Make sure you release the mouse button before you
    release the Control key, otherwise, the file will be moved
    rather than copied.

    2. Using the Control key again, copy the ClassFolder
        directory to the Labs directory.

    Note: To cancel a drag in progress, press the Esc (Escape)
    button on the keyboard before releasing the mouse button.

    3. Change to the Labs directory to see the folder has been
        copied.



____________________
Deleting Folders and files

In this exercise, you'll learn several ways to put folders and files
into the Trash Can, put back a file and delete a folder or file
permanently.

  Putting folders and files into the Trash Can

    1. Click to open the ClassFolder directory.
        Trash Can control

    2. Drag the classfile icon onto the Trash Can control on
        the Front Panel.

    Note: You may also select a folder or file icon, then choose
    Put in Trash from the File Manager Selected menu.

  Putting back a folder or file from the Trash Can

    1. Click to open the Trash Can window on the Front Panel.

    2. Drag the same file from the Trash Can window back to the
        ClassFolder directory in File Manager.

Note: You may also select a folder or file icon, then choose
Put back from the Trash Can File menu.

Files are not actually removed from the file system until the
trash is "emptied." You can only change your mind and restore
a file you've put in the Trash Can if the Trash Can hasn't been
emptied.

The Trash Can control on the Front Panel is a drag-and-drop
zone and need not be open to collect folders and files.

  Deleting a folder and file permanently

    1. Drag the classfile to the Trash Can for the final
        time.

    2. With the  classfile icon selected, choose Shred from
        the File menu.



    3. Click OK in the confirmation dialog box.

    Note: Shredded files can not be recovered unless you have a
    backup mechanism.

    4. Close the Trash Can window.

____________________
Using Folder and File Icons on the Workspace 

Dropping an icon on the workspace/desktop are creates a reference
to the dropped item. This procedure is often used when files and
directories that are several levels deep need to be relocated to
another directory. Rather than starting two File Manager windows,
you drag files and directories onto the workspace temporarily
while you change to another directory.

In this exercise, you'll drag a file from the Labs directory on your
desktop to your home directory in the main File Manager window.

    1. Change to the Labs directory.

    2. Create a new folder named Lab_2.

    3. Change to the Lab_2 folder and create a new folder
        named States.

    4. Change to the States folder and create a new file named
        california with the following contents:

California became a state in 1850.

        Create a second file named alaska with the following
        contents.

What year did Alaska become a state?

    5. Change back to the Labs directory.

    6. Drag the Lab_2 folder to the workspace/desktop.

    7. Double-click to open the Lab_2 folder to see its contents.

    8. In the original File Manager window, from the File menu,
        choose Go Home to return to your home directory.



    9. Change to the States directory in the second File Manager
        window (Lab_2).

    10. Drag the california file to your home directory in the 
          main File Manager window.

    11. Click the Minimize button to close the States File Manager
          window to an icon. States appears as the name of the icon.

    12. Position the pointer over the Lab_2 folder on the
          workspace, and using mouse button 3 choose Remove from
          the Workspace to remove the Lab_2 icon from the
          desktop.

    Please continue to the Intermediate User Skills section of this
    lab.



Intermediate User Skills

In this section of the lab, you'll rename folders and files, set view
options and work with selected menu items.

____________________
Preliminary Steps

The following preliminary steps will put you into the correct
directory in which you will create and work with files.

    1. From the File menu, choose Go Home to make certain you
        are in your home directory.

    2. From the File menu, choose New File and name it:

success

    3. Double-click to open the success file.

    4. In the Text Editor window, type the following text:

The only place where success comes before work is a
dictionary.

-Vidal Sassoon

    5. From the File menu, choose Save.

    6. From the File menu, choose Close to close the Text Editor
        window.

    7. In File Manager, from the File menu, create a new folder
        and name it:

Sayings

    8. Drag the success file into the Sayings folder. Resize
        the window if necessary to easily see the folder.



____________________
Renaming Folders and Files

In the CDE File Manager, there are two ways in which to rename
folders and files.

  Renaming folders and files

    1. Select the Sayings folder.

    2. From the Selected menu, choose Rename.

    3. In the text box beneath the folder, type:

Quotations

    4. Press Return.

    5. Open the Quotations folder.

    6. Click the name of the success file icon to change it to a
        text box, then type the new name:

sassoon

    7. Press Return.

    8. Click the ..(go up) icon to go to the parent folder.

        You should be in your home directory.

____________________
Setting View Options

In File Manager, the View menu allows you to set view options
and see hidden files.

  Setting view options

    1. From the View menu, choose Set View Options.

    2. Change the Placement option to: As Placed



    3. Change Representation to: By Small Icons

    4. Click OK, and look for the changes in the File Manager
        window.

    5. Drag several folders to a different spot in the File
        Manager window. What happens to the folder?

________________________________________________
________________________________________________

    6. What does the Clean Up item on the View menu do?

________________________________________________
________________________________________________

    7. Return the placement of icons to Rows and Columns.

    8. Look at the footer of the File Manager window. Write in
        the number of items _________, and the number of hidden
        items __________.

    9. From the View menu, choose Show Hidden Objects. How
        many are hidden how? __________

    10. What kind of files are "hidden" and why are these files
          normally hidden from daily view?

________________________________________________
________________________________________________
________________________________________________

    11. From the View menu, choose Show Hidden Objects again
          to hide the files from view.

    12.  From the View menu, choose Set View Options.

    13. Change the Show option to: By Tree, then select Folders
          and Files and click OK.



____________________
Using Selected Menu Items

In the following exercises, you'll work with various items from the
Selected menu. Folders must be "selected" in order for these items
on the menu to work.

  Using the Selected menu

     1. The two items identified below appear on the Selected
         menu. On the lines provided below, identify the difference
         between them.

  a. Open in Place

  b. Open New View

________________________________________________
________________________________________________
________________________________________________

     2. If you want to change permissions for a particular file or
         folder, what menu item is used and where is it found?

________________________________________________
________________________________________________

    Please continue to the Advanced User Skills section of this lab.



Advanced User Skills

In this section of the lab, you'll work with linked files, find folders
and files and use pop-up menus.

____________________
Preliminary Steps

     1. In your home directory, create a new file and name it:

fun.file

     2. Open the file, and type the text as it appears:

There are soome mispeled woords in this document.

     3. Save the file, and close the Text Editor window.

         In a moment, you'll create a linked version of the file and
         place it in another directory. You'll then make a change to
         the file and see the result.

____________________
Linking Folders and Files

A link icon is a copy of a copy that points to the same file or folder
as the original icon. Any changes you make to one file will be
reflected in the other file.

  Linking and unlinking a file

     1. Select the fun.file

     2. From the Selected menu, choose Copy As Link.



     3. In the Destination Folder dialog box, change the
         destination directory to:

~/Labs/Lab_2

     Note: The tilde (~) is a shortcut for all the folders in the path
     of your home directory, for example: /export/home/trainer

     4. Change the file name to:

linked.file

     5. Click OK.

     6. Change to the Lab_2 directory and open the file.

     7. Correct the spelling, save the file and close the Text
         Editor window.

     8. Return to your home directory and open the original
         fun.file.

         Any editing changes you make to a file with links are
         reflected in all folders, since there is really only one file,
         not multiple copies of it.

     9. Close the Text Editor window.

  Linking a folder

     1. Using the Go To dialog box from the file menu and the
         following path, change to the Lab_2 directory.

~/Labs/Lab_2

     2. Create a new folder and name it:

Vacations

     3. Click once to select the Vacations folder.

     4. From the Selected menu, choose Copy As Link.

     5. In the dialog box, specify your home directory, and click OK.



     6. Change to your home directory.

     7. In your home directory, use the Control key to copy the
         fun.file into the Vacations subdirectory.

     8. Now change to the Labs/lab_2/Vacations directory
         to see a copy of the fun.file.

____________________
Finding Folders and Files

The Find menu option allows you to search through the file system
hierarchy using search criteria such as the name of the folder or
file, or in the case of a file, the contents. Wildcard characters can
be used when specifying the name of a file, for example, the
asterisk (*).

  Finding folders and files

     1. From the File Manager File menu, choose Go Home to
         change to your home directory.

     2. From the File Manager File menu, choose Find to access
         the window.

     3. Use the alaska file as the search criteria and enter it into
         the text box. Click Find.

     4. When will you get an error message indicating the file is
         not found?

________________________________________________
________________________________________________

     5. In the Find window, what do the Put in Workspace and
         Go To options do?

________________________________________________
________________________________________________
________________________________________________
________________________________________________



Review Questions

1. In CDE, how is the parent folder displayed?

    _________________________________________________________
    _________________________________________________________

2. Using a menu, describe how to change to the home folder.

    _________________________________________________________
    _________________________________________________________

3. State when drag and drop works and does not work in CDE.

    _________________________________________________________
    _________________________________________________________
    _________________________________________________________

4. Identify 2 ways to use the Control key in File Manger.

    _________________________________________________________
    _________________________________________________________
    _________________________________________________________

5. Identify the menu on which File Manager options are found.

    _________________________________________________________
    _________________________________________________________



A P P E N D I X  A
Answer Key



Lab 1: Introduction to the Desktop

1. What CDE control is used for lockscreen?

     The Lock control, found on the Front Panel is used to lock the       
     display.

2. Correctly name the 3 mouse buttons.

     Mouse button 1
     Mouse button 2
     Mouse button 3
     
3. What CDE control provides access to a command line interface with
    prompt? 

    The Terminal control, found on the Workspace Menu and Tools     
    submenu.

4. Define Close in CDE terminology.

     In CDE terminology, "close" means to quit the tool/desktop.          

5. How do you discern a "tear-off menu" from other menus?

    A tear-off menu has a dotted line at the top of the menu.                 

6. When is using multiple workspaces advantageous?

     Workspaces are like separate screens of windows that help you       
     organize your work. One workspace could contain tools to create   
     reports: spreadsheet, desktop publishing application, graphics         
     package.

     A second workspace could contain tools that you check                    
     periodically during the day: Mailer, Calendar, Netscape



7. Identify the differences between using Help Manager and using the
    Help menu. 

    Help Manager lists all the on-line help registered on your system.    
    You are able to search for a topic, use an index, and click                
    hypertext.

    The Help menu is found in the upper-right corner of most              
    applications and CDE tools. It enables you to request specific types 
    of help including an overview about the application, tasks, table of 
    contents, summary information about application components, and
    context-sensitive (on-item help).

8. What is the name of the CDE control used to customize the desktop?

    Style Manager or Desktop Controls

9. What control is used to customize login?

    The Startup control found in Style Manager is used to customize    
    login.

Lab 2: File Manager
1. In CDE, how is the parent folder displayed?

    The .. (go up) icon represents the parent folder, or choose Go To      
    from the File menu.

2. Using a menu, describe how to change to the home folder.

     Choose Go Home from the File menu.

3. State when drag and drop works and does not work in CDE.

    Drag and drop does   not   work on minimized folder icons.  

    Drag and drop   does   work when dragging a Text Editor icon in File   
    Manager to the Printer control on the Front Panel.

    Dropping an icon on the workspace/desktop area creates a               
    reference   to the dropped item. The original icon still appears in         
    File Manager.

4. Identify 2 ways to use the Control key in File Manger.



    To copy a folder or file icon: Control + Select+ Drag + Drop

    To select multiple folders/files: Click first icon with mouse               
    button 1, hold down Control, then select additional icons.
    
5. Identify the menu on which File Manager options are found.

    File Manager options are found on the View menu. Properties for   
    selected files/folders are found using the Selected menu.


