
Open Gateways Curriculum
for Teachers 1 

Module 1: Introduction to StarOffice™ 6.0 Office Suite
Module 1 of the Open Gateways Curriculum for Teachers  introduces participants to the
various features and capabilities of the StarOffice™ 6.0 Office Suite of productivity tools.
This module is designed to present an overview of the features, menus and icons as well as
the basics of how to use the various applications available in StarOffice™ 6.0.

Module 1 is not formatted as a step-by-step training guide. It is designed to be used as a
reference while you build upon your knowledge of the tools available in the Office Suite.

PREREQUISITE

Module 1 is a prerequisite for all subsequent Open Gateways Curriculum
for Teachers training modules.
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Learning Outcomes

Upon completion of Module 1, you should be able to meet the following Learning
Outcomes:

• List the features/applications of the StarOffice™ 6.0 Office Suite

• Launch the application on various platforms: 
Solaris™ Operating Environment, Linux, and Microsoft Windows  

• Identify the basic screen elements, menus and icons

• Organize and save documents

• Know how to use StarOffice™ Help

• Optional: Become familiar with the Shortcut Keys 

Features of the StarOffice™ 6.0 Office Suite

The StarOffice™ 6.0 Office Suite is a powerful, multiplatform office productivity tool that
includes a word processor, spreadsheet, presentation software, draw program,
database client (Software AG Adabas D), graphics program, photo editing, Web
publishing and more. In other words, you can access programs to write letters, create
newsletters, design graphics,
analyze data, prepare slide show
presentations, and to save
documents as HTML documents for
the Web. Its user interface is
intuitive and easy to use. The
StarOffice™ Office Suite is
interoperable with Microsoft Office
file formats such as ".doc", ".ppt",
and ".xls". 
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StarOffice™ Applications

The following applications will be addressed in the Open Gateways Curriculum for
Teachers Training Guides:

• StarOffice™ Writer (word processing)
• StarOffice™ Calc (spreadsheets)
• StarOffice™ Impress (slide show presentations)
• StarOffice™ Draw (graphics)

More advanced applications are accessible through additional StarOffice™ 6.0 Office Suite
modules:

• StarOffice™ HTML (Web publishing)
• StarOffice™ Basic (Application Programming Interface)

Functions & Interface

 The interface is intuitive and easy-to-learn. Many of the standard features are available and
accessed in a similar manner throughout StarOffice™ 6.0. 

TIP

Since StarOffice™ applications are designed to work together, many features
and functions apply to all of them. For example, many of the standard
features in Writer, such as text formatting and image handling, are available
throughout the StarOffice™ 6.0 Office Suite.

Variations in Operating Systems

Launching

The primary audience of this curriculum will be utilizing the Solaris™ Operating
Environment. This training guide shows screen shots and methods for launching the
application and saving documents in both Windows and Solaris and makes mention of how
to launch in the Linux environment.

Saving & Retrieving

The StarOffice 6.0 application interface, features, menus and icons are the same for each
operating system. Differences exist only for launching the software and saving documents.
Saving documents varies due to the differences in file hierarchy and how files are stored.
Files are normally stored on a hard drive in the Microsoft and Linux environments, while
files are stored on the centralized server in the Solaris environment.
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Launching StarOffice™ 6.0

The StarOffice™ 6.0 Office Suite is multiplatform and available on the Solaris™
Operating Environment, Linux, and Microsoft Windows platforms. The application has the
same “look and feel” on each platform. Although there are slight variations depending on
the operating system and setup, the steps to launch the application suite are similar across
platforms.

This section presents how to launch the application in the following environments.

• Solaris

• Windows

• Linux

Solaris™  Operating Environment

To launch StarOffice™ 6.0 in the
Solaris™ Operating
Environment:

1. Click the StarOffice 6.0 icon
on the Common Desktop
Environment (CDE) Front
Panel as shown in Figure 1.1.

2. Select the desired
StarOffice™ 6.0 application,
e.g. Text Document,
Spreadsheet, Drawing,
Presentation, etc. 

3. To open a new StarOffice™
document from within any
StarOffice™ document, from
the Menu bar choose File >
New and then select the
application.

You may have multiple modules
and documents open at the same
time. 
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Figure 1.1



Microsoft Windows

To launch the StarOffice™ 6.0 Office Suite in the Microsoft Windows operating system,
1.  Click the Start button on the Task bar to display the Start Menu. 

2. Select Programs > StarOffice 6.0. 
3. Then select the desired StarOffice application, i.e. Text Document, Spreadsheet,

Drawing, etc. See Figure 1.2.

4. This will launch one window for each selected module.
5. To open a new StarOffice™ document from within any StarOffice™ document,

from the Menu bar choose File > New and then select the application.

Linux

Launching the StarOffice™ 6.0 Office Suite in the Linux environment is similar to
Windows.

1. Access StarOffice via the Application Starter button on the KDE Front Panel.

2. Then select the desired StarOffice™ application, i.e. Text Document, Spreadsheet,
Drawing, etc. 

3. Working in the StarOffice™ application within Linux is the same as the other
environments. 
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Figure 1.2         



Saving Documents

Saving your work repeatedly is a MUST! 

Each time you open a new StarOffice™
file, a blank document window will
appear as “Untitled #.” “Untitled 1” will
be the first document that is saved
without a name, and “Untitled 2” would
signify the second document that has
not yet been saved, etc.

The examples below demonstrate how
to save a Writer text document in
Solaris and Windows operating
environments.

Solaris  – Saving a Document in Work

1. From the Menu bar, choose File > Save As.

 

Figure 1.3

The Save As window, as shown in Figure 1.3, appears. 

2. In the upper right of the window are icons for navigating
through your computer's directory structure (Figure 1.4).
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Figure 1.4 

StarOffice™ will automatically saveStarOffice™ will automatically save
extensions to your StarOffice files.extensions to your StarOffice files.

•• Writer – Text Document: Writer – Text Document: .sxw.sxw

•• Calc – Spreadsheet: Calc – Spreadsheet: .sxc.sxc

•• Impress – Presentation:Impress – Presentation: .sxi.sxi

•• Draw – Graphics: Draw – Graphics: .sxd.sxd

•• HTML – Web Publishing: HTML – Web Publishing: .html.html



The first button is the Up One Level button. This button will open the
directory one level above the current directory.

The second button is the New Directory button. This will create a new
directory in the current directory.

The third button is the Default Directory button. If your computer is
correctly configured, this should open your Work directory.

If the Default Directory is not set, use the directory names displayed in the
Save As window, along with the Up One Level button, to navigate to your
Work directory. Though the exact path to the directory will vary, it should
be located in a folder within Export > Home > Office60.

3. Click in the field labeled File Name. Name your file using the common naming
conventions. 

4. Click on the arrow next to the Save as Type field. You should see a list similar to the
one in Figure 1.5.

Figure 1.5

This allows you to save your file in other useful formats, such as StarWriter 5.0,
Microsoft Word, or HTML, making your document cross-platform.

5. Click on the Save button. Your document is now saved in your Work directory. 

TIP

Now you can save changes to your document by pressing Ctrl+S on your
keyboard or by choosing File > Save from the Menu bar.
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Windows – Saving a Document in My Documents

1. To save a new document, pull down from to the Menu bar, and choose File > Save As.
The Save As window as shown in Figure 1.6 appears. 

2. On the left side are icons that open special folders on your computer. Click the icon that
is labeled My Documents. If you do not select a subdirectory (folder), the document
will be saved in the My Documents folder. 

3. You must first navigate to the directory in which you want to save your file. As
previously mentioned, you can create a new directory from within StarOffice™ by
clicking the New Folder icon and naming it. Otherwise, double click on each
subdirectory to reach your desired
location.

4. To enter a name for the document,
click in the field labeled “File
Name.”

5. Click on the arrow the the right of
the Save as Type field. You should
see a list similar to the that shown
in Figure 1.7.
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Figure 1.6

Figure 1.7



6. This allows you to save your file in other useful formats, such as StarWriter 5.0,
Microsoft Word, or HTML, making your document cross-platform.

7. Click on the Save button. Your document is now saved in your My Documents
directory. You can save changes to your document by pressing Ctrl+S on your keyboard
or by choosing File > Save from the Menu bar.

Windows - Opening Documents

1. From the Menu bar, choose File > Open. A window similar to Figure 1.8 appears.

Figure 1.8

2. Enter the name of your file in the File name field or single click a file, and click Open.

TIP

It is easier to double-click on the desired file displayed in the Open window.
The current directory will be the directory in which you last saved your work.
Figure 1.6 shows the My Documents folder. 
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TIP

If you are not in the desired directory, navigate to it via the displayed
directory names and/or the Up One Level button. 

To move “up”: 
Click on the Up One Level button to move up one level at a time.

To move “down”: 
Double click on a directory folder to move down into that folder.

3. Take special note of the Files of type dropdown box. Using this, you can select open
files of many various types, including Microsoft Word. Setting this field to All Files will
display the types of files you can import into StarOffice™ Writer.
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Solaris - Opening Documents

4. From the Menu bar, choose File > Open. A window similar to Figure 1.9 appears.

5. Enter the name of your file in the File name field or single click a file, and click Open.

TIP

It is easier to double-click on the desired file displayed in the Open window.
The current directory will be the directory in which you last saved your work.
Figure 1.7 shows the spreadsheet sample folder. 

If you are not in the desired directory, navigate to it via the displayed
directory names and/or the Up One Level button. 

To move “up”: 
Click on the Up One Level button to move up one level at a time.

To move “down”: 
Double click on a directory folder to move down into that folder.

6. Take special note of the File Type dropdown box. Using this, you can select open files
of many various types, including Microsoft Word. Setting this field to All Files will
display the types of files you can import into StarOffice™ Writer.
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 Figure 1.9



Password Protection
You can protect specific files to ensure others do not read or copy your work by setting a
password for each file you want to protect. When saving the file for the first time or with
the File > Save As... command, enter a password in the Save dialog box (Figure 1.10).

1. Click the “Save with Password” box.

2. Click the Save button

3. Enter a password, and confirm the same password. 

Asterisks will appear in these input fields. 

Be careful! Write down your password! DO NOT LOSE YOUR PASSWORD.
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Figure 1.10



Menus

The StarOffice™ 6.0 Office Suite provides menu options and tools that are relevant to the
tasks you perform. Each document opens into its own window. This window is “self-
contained,” or in other words, each is its own application. If you are in a drawing document,
that window contains all the menus and tools needed to draw. The toolbars vary according
to the application in which you are working. They are dynamically integrated with each
application.

See the following for a description of the menus, submenus and dialogs opened in an active
document.

The commands that can be used for editing, viewing, sequencing, formatting and
printing a document or its contents can only be accessed if the document is open and
active. “Active” means that the document has to be in front of any others on the
screen. An object has to be selected before you can apply or utilize commands, such
as formatting. 

The menus are “context sensitive.” The menu commands that are relevant to the work
currently being carried out will be available. If the cursor is located in text, then all of
the text-related menu commands are available. If, for example, you have selected
graphics in a document, then you will see all of the menu commands that can be used
to edit graphics.

See Figure 1.6 for the location of the Menu bar.

Active Menus

By default, when you pull down a menu,
you see only the menu entries that can be
started. The other inactive menu items are
hidden. If you wish to see the inactive
menu entries as gray entries:

1. From the Menu bar, choose: 
Tools > Options > StarOffice > View

2. Mark the Inactive Menu Entries
field. Figure 1.11 shows this option as
unmarked by default.
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Figure 1.11



Below is a brief overview of the pull-down menu items on the Menu bar. 

TIP

There are numerous ways and shortcuts to access StarOffice™ commands
and  functions; however, all commands can be accessed from within the
Menu options.

File

File contains commands relevant to working with documents such as creating, opening,
closing or printing new documents, as well as entering document information. To close the
active document, click Close. To close StarOffice™, click Exit.

Edit

Edit lists commands for undoing or repeating the last action, copying and pasting using the
clipboard, accessing the Navigator to aid you in working with long and complex
documents, for example, with functions for editing indexes and embedded objects.

View

View contains commands used for controlling the screen display of the StarOffice™
window when a text document is active and the “view” of the document contents. You can
determine which toolbars to display or the scale of the document on screen.

Insert

Insert contains all necessary commands for inserting new elements in your document. This
includes sections, footnotes, notes, special characters, graphics, objects from other
applications, etc.

Format

Under Format are the commands used to format individual characters, paragraphs or entire
pages. When you select an object, such as a graphic or a table, different format commands
appear. For instance, when you select a graphic object, only the applicable commands are
available. Access to the Styles Catalog is also found here.
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Tools 

Tools provides the Spellcheck or Thesaurus as well as control for the AutoCorrect feature,
define page and chapter numbering, etc. You can also customize the toolbars, menus,
shortcut keys and general program settings.

Window 

In the Window menu, you can open a New Window and see the list of open StarOffice™
documents.

Help

The Help menu serves to start and control the StarOffice™ Help system. This is also where
you can turn on or off the Help Agent as well as Tips and Extended Tips. (It is
recommended that you keep Extended Tips “on” for the first few uses of the software.)

Using StarOffice™ Help

StarOffice™ 6.0 online help offers an easy-to-use interface and thorough information on
the software. The Help system presents an overview, details about functionality, features,
functions, general instructions, and shortcut keys available within each of the following
modules:

• StarOffice™ Writer
• StarOffice™ Math
• StarOffice™ Impress
• StarOffice™ Draw
• StarOffice™ Calc
• StarOffice™ Basic

Figure 1.12

To use the online Help system:

1. Choose Help from the Menu Bar as shown in Figure 1.12.

2. Select Contents. 
Help is context-sensitive and will open into the “Welcome” Help screen associated with
the active StarOffice™ document. See Figure 1.13 on the following page.
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The following presents the primary tabs for accessing Help topics:

• Contents – Information about Main Help Topics

• Index –  Keyword Search in the Help

• Find – Full-Text Search

Help Agent

Under Help Agent you toggle the Help Agent on and off. If this field is marked, the Help
Agent will be displayed automatically in selected situations.
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Figure 1.13 



Toolbars & Icons

Figure 1.14 

StarOffice™ 6.0 provides tools that are relevant to each application. The
interfaces are similar throughout, yet the functions may vary.

Each StarOffice™ 6.0 application contains the following toolbars:

Title Bar

The Title bar contains the title of the document and the application.

Function Bar

The Function bar is the tool bar at the top of the StarOffice™ window. It contains icons for
the functions that are used everywhere.
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Main Toolbar Icons

Use the icons on the Main toolbar to insert various objects into your document and quickly
access the most frequently used functions. The icons on the Main toolbar vary for each type
of application. See Figure 1.14 for the location of the Main toolbar.

TIP

Icons on the Main toolbar that have a small green arrow indicate there are
multiple options available for that function. Hold down the mouse for a “long
click” to open an associated floating toolbar.

Insert

Long click here to open the floating toolbar containing various functions for
inserting frames, graphics, tables, and other objects. A short click activates the
tool shown on the icon.

Insert Fields (HTML Document)

Click this icon to open a submenu where you can choose fields to insert. Long-
click to open the submenu; short-click to open the Fields dialog.

Insert Objects

The Insert Objects floating toolbar containing various icons for inserting
objects. If you have selected a function, the corresponding icon will appear on
the main toolbar. A short click reactivates the last tool used, and a longer click
enables you to select another function from the floating toolbar.

Show Draw Functions

The Show Draw Functions icon opens a floating toolbar with various draw
options. 

Form

The Form icon opens a floating toolbar with the tools and functions needed to
create an interactive form.
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Edit AutoText

Use Edit AutoText to organize reusable text passages. Save text, including
formatting, graphics, frames, etc., in a specified text block theme collection.
You can then insert these text blocks in a document by entering the respective
shortcut and pressing F3.

Direct Cursor On/Off

Click this icon to activate or deactivate the direct cursor. Click on an area in
your document and start typing. 

Spellcheck

Use this function to start the spellcheck.  StarOffice™ 6.0  is able to perform a
spellcheck for a selected piece of text, the current document, for headers and
footers, indexes and footnotes.

AutoSpellcheck

If this function is active, the automatic spellcheck is activated.

Find & Replace

Use this command to find text and/or formats and replace them where
necessary.

Data Sources

Turn the data source view on and off.

Nonprinting Characters

View or hide the nonprinting characters in your text, such as line breaks, tab
stops and spaces.
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Graphics

If this icon is activated, no graphics will be displayed, only empty frames as
placeholders. This often saves processing time for documents with a lot of
images.

Online Layout

Select Online Layout to display the StarOffice™ 6.0 Writer document as if it
were an HTML document. This function is especially useful when creating
Internet documents.

Changing Icon View

You can change the display of the toolbar icons and make them larger or 3D.

1. Choose Tools > Options > StarOffice.

2. In the View register, unmark Flat buttons.

3. Click OK to confirm the new settings.

The Flat buttons check box switches between flat and 3D view. 

The Large buttons check box switches between large and small icons.

Object Toolbar

The Object bar is “context sensitive” and varies according to the application and formatting
options available. For example, the Object bar of the text input mode offers several text
formatting options such as bold, italics, alignment, styles, etc. The toolbar that appears
when objects are selected contains the most important functions for formatting and
positioning objects. The Object bar that appears when a drawing object is selected contains
the most important functions for editing drawings, such as line width and color, and
positioning options.

See Figure 1.6 for the location of the Object toolbar.
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Status Bar

The status bar displays information about the active document and can be configured under
Tools > Customize. It essentially gives you current document “status.” 

Scale

This is where you can see and edit the current page display scale.

If changes to the document have not yet been saved, an asterisk (*) is displayed in this field
on the status bar. This also applies to new, not-yet-saved documents.

See Figure 1.6 for the location of the Status bar.

Convert Documents created in MS Office 

You can open a Microsoft document, such as a .doc word processing file, and save it as a
.doc file without converting to StarOffice format. 

Document Converter

The AutoPilot converts documents and templates from the binary format from StarOffice
versions prior to 6.0, as well as documents from Microsoft Word, Excel and PowerPoint.
The source files are only read, not edited. New target files are written (with the new file
name extension) in the same or a new folder.

1. Pull down from File > AutoPilot > Document Converter

2. Follow the AutoPilot prompts.
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Using Shortcut Keys

The following provides general default shortcut keys used throughout StarOffice™ 6.0. 

A great deal of your application's functionality can be called up by using shortcut keys. For
example, the Ctrl+O shortcut keys are shown next to the Open entry in the File menu. (If
you want to access this function by using the shortcut keys, press and hold down the key
Ctrl and then press the O key. Release both keys after the dialog appears.)

When operating your application, you can choose between using the mouse or the keyboard
for almost all of the operations available.

TIP

Shortcut keys are not case-sensitive.

General Shortcut Keys

Shortcut keys are quick ways to access menu commands using the keyboard instead of the
pull-down menus. Not all commands have shortcuts. Commands with shortcuts are shown
on the right side of the pull-down menu lists next to the corresponding command. 

Shortcut Keys Effect
Enter key Activates the focused button in a dialog
Esc Terminates the action or dialog. If in StarOffice Help: goes up one level. The cursor

is positioned in the URL on the Function bar: returns the cursor to the document. If
the URL has been selected, you have to press the key twice.

Spacebar Toggles the focused check box in a dialog
Cursor keys Changes the active control field in an option section of a dialog
Tab Advances focus to the next section or element in a dialog.
Shift + Tab Moves the focus to the previous section or element in a dialog
Alt+Down Arrow Opens the list of the control field currently selected in a dialog. These shortcut keys

apply not only to combo boxes but also to icon buttons with pop-up menus. Close
an opened list by pressing the Escape key.

Del Deletes the selected item(s) into the recycle bin.
Shift+Del Deletes the selected item(s) without putting them in the recycle bin.
Backspace When a folder is shown: goes up one level (goes back)
Ctrl + Tab Goes to the next document that is open (except when positioned at the start of a

header, instead a tab is inserted).
Shift + Ctrl + Tab Goes to the previous document that is open.
Ctrl + O Opens a document
Ctrl + S Saves the current document
Ctrl + N Creates a new document
Shift+Ctrl+N Opens Templates and Documents dialog
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Ctrl + P Prints document
Ctrl + Q Exits application
Ctrl + X Cuts out the selected elements
Ctrl + C Copies the selected items
Ctrl + V Pastes from the clipboard
Ctrl + A Selects all
Ctrl + Z Undoes last action
Ctrl + F Calls the Find & Replace dialog.
Ctrl + Shift + F Searches for the last entered search term.
Ctrl + Shift + J Toggles the view between Full screen mode/normal mode
Ctrl + Shift + R Re-creates the document window
Ctrl + I The Italic attribute is applied to the selected area. If the cursor is positioned in a

word, this word is also marked in italic.
Ctrl + B The Bold attribute is applied to the selected area. If the cursor is positioned in a

word, this word is also put in bold.
Ctrl + U The Underlined attribute is applied to the selected area. If the cursor is positioned

in a word, this word is also underlined.
Ctrl+Shift+O Sets the cursor on the Load URL field on the Function bar.
Alt + O In the Spelling dialog, the word that was originally marked as unknown/incorrect

(original) will be transferred to the input row (word).

Shortcut Keys Using the Function Keys

Shortcut Keys Effect
F1 Starts the StarOffice Help

In the StarOffice Help: jumps to summary page.
Shift + F1 Context Help
Ctrl+F4 or Alt+F4 Closes the current document 

(close StarOffice when the last open document is closed)
F6 Sets focus in next subwindow (e.g. document / data source view).
Shift+F6 Sets focus in previous subwindow
Shift+F10 Opens the context menu
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