


Learning Outcomes

Upon completion of Module 2, you should be able to:

Format a text document by:
• Setting page layout and establishing margins
• Using the functions on the Object Toolbar
• Inserting headers and footers
• Formatting text into columns
• Applying bullet and numbering format

Use the following Writer features:
• Object Toolbar
• Stylist
• Spellcheck
• AutoSpellcheck
• AutoPilot & Templates

Work with Objects by:
• Inserting charts
• Inserting graphics from the Gallery
• Inserting images
• Wrapping text around images

Save text documents in various formats 

Import text documents from MS Word
• Setting page layout and establishing margins

Print a text document

PRACTICE

• Practice exercises are included at the end of key sections to
reinforce the concepts and to provide hands-on practice.

• Practice exercises require no more than 2-4 minutes.
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Overview of StarOffice™ 6.0 Writer

The StarOffice™ Writer application is the word-processing program in the StarOffice™ 6.0
Office Suite that can be used to create personal documents, business letters, newsletters,
and various other types of text documents.

Writer allows you to either create a new blank document or work from a series of templates
customized to specific types of documents. 

The StarOffice™ Writer module also offers the following features:
• Stylist
• Spellcheck
• Dictionary and Thesaurus
• AutoCorrect and AutoComplete
• Find and Replace
• Special Characters
• AutoPilot

Creating, Saving, Opening Documents

This section will ensure you are comfortable with the skills learned in Module 1 to create,
open and save documents.

Creating a New Text Document

Begin a new, blank word processing document:

1. If StarOffice™ is not launched, select StarOffice > Text Document from your Solaris
CDE Front Panel or your Windows Start Menu.

OR

2. To open a new StarOffice™ Writer text document from within any StarOffice™
document, from the Menu bar choose File > New > Text Document.

A blank document window will appear as “Untitled1.” Your cursor is placed at the
beginning of this document, where you can begin typing. 

3. Enter some text to experience how characters flow in a new text document. Do not focus
on formatting, which will be covered later.
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TIP

As you type, your cursor will automatically descend to the next line. Pressing
the Return key will manually enter new “blank paragraph marks” which will
allow you to insert a blank line or start a new paragraph.

Saving a Text Document

Save your work...when you begin, while you are
working, when you are complete!

1. From to the Menu bar, choose File > Save As.

2. The Save As window appears. Navigate through
the hierarchy to save in the proper directory/file
folder. 

3. Give the file a name, and click on the Save button.

TIP

After initially saving the file, File > Save (Ctrl+S) will save revisions to the
same file. 

Make Ctrl+S your friend! 

4. Close your document to practice opening it for later revisions.
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Opening a Document

1. From the Menu bar, choose File > Open.

Figure 2.1 displays the Solaris operating system. The Open window will vary depending
upon your operating system and your default settings.

2. Find a recently-saved document. Enter the name of your file in the File name field, or
single click a file then click Open to navigate. 

TIP

Default files for Writer documents (with .sdw extensions) will appear. You
can view files of many various types, including Microsoft Word, by changing
the default in the Files of type dropdown box. Setting this field to All files
[*.*] will display the types of files you can import into StarOffice™ Writer as
shown in Figure 2.1.

PRACTICE 

• Practice opening and saving Writer documents to various
directories. 
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Figure 2.1



Formatting a Document

StarOffice™ Writer is equipped with a number of tools, both simple and advanced, that
allow you to change the look and feel of your document. In this section, you are going to set
the documents margins and page layout.

Margins

Margins to determine the amount of blank space on the left and right of your document, and
how far, if at all, you want each paragraph to indent. 

Paragraph Margins

Paragraph margins are controlled by three sliding arrows at the top of the Writer
document, below the Object Bar (Figure 2.2).

Figure 2.2

• The top left arrow controls paragraph indenting. 
Click in a paragraph, and slide arrow to the right to indent the first sentence.

• The bottom left arrow controls the left margin. 
Click in a paragraph, and slide arrow to the right to indent horizontal position.

• The bottom right arrow controls the right margin. 
Click in a paragraph, and slide arrow to the left to change right margin.

TIP

To change the margins for more than one paragraph, select the
paragraphs by holding down the mouse button and selecting the target
paragraphs. Then, slide the paragraph margin arrows.
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Document Margins

1. To change margins for an entire document, from the Menu bar choose:
Format > Page

2. The Page Styles
window appears as
shown in Figure 2.3.

3. Adjust Left, Right,
Top, Bottom margins
by entering the exact
number or using the
associated arrow keys
to increase or decrease
respective margins.

4. Click OK when
complete.

PRACTICE

• Experiment with adjusting paragraph margins to adjust
indenting, left and right margins.

• Experiment with adjusting page margins.
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Layout & Formatting a Page

The Object bar  shown in Figure 2.4 contains simple tools for changing page layout and
formatting. Its functions are displayed below by associated number, from left to right. Note
that formatting is applied to selected text or to text you are about to type.

                 1                                       2                         3                4     5     6        7     8     9    10     11    12                   13   14   

                                                                                                                                            Figure 2.4

1. Dropdown menu will change the predefined Style of the the text. (See Stylist section.)

2. Dropdown menu will change the font of the text.

3. Dropdown menu will change the size of the text.

4. Button will toggle bold text on and off.

5. Button will toggle italicized text on and off.

6. Button will toggle underlined text on and off.

7. Align Left button. Aligns selected paragraph to the left of the page.

8. Centered button. Centers selected paragraph in page.

9. Align Right button. Aligns selected paragraph to the right of the
page.

10.Justified button. Adjusts paragraph for left and right alignment with
“square” edges, like a newspaper column.

11.Button toggles Numbering on and off to create a numbered list. (This button
automatically appends a number to your paragraph. When you press return, your
subsequent paragraph will have the successive number assigned to it.)

Click the button again to turn Numbering off.

To insert a new line without yet appending the next number in the list, press
Shift along with the Enter or Return key.

12.Button toggles Bullets on and off to create a bulleted list. (This button automatically
appends a bullet to your paragraph. When you press return, your next paragraph will be
bulleted.) 

Click the button again to turn Bullets off.

To insert a new line without yet appending a new bullet, press Shift along
with the Enter or Return key.
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13.Button changes text color. 
To open a color palette (Figure 2.5), click and hold mouse down.
Choose your desired color. 

14.Button changes text background color.
To open a color palette, click and hold it down. 
Choose your desired color. 

PRACTICE

• Experiment with formatting to have your document contain one
bulleted list, one numbered list, and an example of all three
types of paragraph alignments.

• Use the other buttons to experiment with the look and color of
text. 

Setting Zoom Factor

Formatting options are applied to the
actual file and affect who it will look
when printed. To vary how the document
looks only on the monitor, you can affect
the Zoom factor. In other words, you can
magnify or reduce the size of the
document on the screen.

1. Set the zoom factor to a comfortable
point for viewing your working
document. Choose View > Zoom from
the Menu bar. You can choose to
zoom to a particular percentage of the
print size, or you can zoom to a preset
format. See Figure 2.6.

2. Once you have selected your desired
zoom level, click OK. 
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Figure 2.6



Using the Stylist

Styles make different parts of your document uniform,
such as headings, captions, or special selections of text.
The Stylist (Figure 2.7) is a floating window that displays
document Styles. 

The Stylist displays preset styles and allows you to create
new styles.

When you start StarOffice™ Writer for the first time,
certain predefined Styles apply to all document types.
New, blank documents will contain these fixed settings,
which together form the default template.

Opening the Stylist

Every time you create a new document or open an existing
one, the Stylist should be open by default. To open the
Stylist window, choose: 
Format > Stylist (F11)

To turn off the Stylist, deselect:
Format > Stylist (F11)
(Subsequent new Text files will open without the Stylist window.)

TIP

By editing the Styles using the Stylist, you edit everything associated with it
in a document. 

Styles for characters, paragraphs, frames, numbered lists, etc. are always
saved with the document.
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Applying a New Style

1. Change the color, size, or formatting of some text in your document, for example, a
document heading or section title.

2. You'll “copy” this format to create a new Style. Select
the formatted text.

3. Click on the New Style from Selection button shown
in Figure 2.8.

4. Enter a name, then then click OK.

You can now use this Style on any new text.

Modifying a Style

If you change this style, it will change all instances (copies) of that style in the document.
There are a couple ways to modify a Style.

Modify by Example:

1. Select some of the text that is formatted with the style, and make another small change,
such as changing the color. 

2. Click the Update Style button, which is the black button next to the red circle in Figure
2.8.

Modify by Establishing Settings:

1. Right click the Style name in the Stylist window, and select Modify.

2. The Style formatting dialog box will display. Select the desired  formatting changes.

3. Click OK when done. 

4. If necessary, click Reset to return to your original Style prior to modifying the settings.

TIP

If there was any other text in your document with that Style, notice that it
now looks like the text you just changed. From now on, any time you use that
Style, your new changes to it will be in effect.
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 Figure 2.8



PRACTICE

• Practice with Styles and the Stylist. 

• Apply some existing Styles to your document and then
establish some new Styles. 

• Modify at least one of your new Styles.

• Ensure you know how to open and close the Stylist window.

Inserting Headers and Footers

Headers and footers are sections of similar content on each page of your document, such as
the footer in this document that contains the name of the module and the page number. 

Headers
1. From the Menu bar, choose: 

Insert > Header > Default
2. Enter some identifying information about the document, such as a title.
3. Click on the main body of the document when done. This header will now appear on

every page of your document.

Footers
1. From the Menu bar, choose: 

Insert > Footer > Default
2. Click on the new box that appears on the bottom of the page. 
3. From the Menu bar and choose: 

Insert > Fields > Page Numbers
4. Click on the Align Right button in your layout toolbar. The page number will now be

displayed at the bottom of every page.
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Formatting Text into Columns

Newsletters, brochures, and other business documents often have their content arranged in
multiple columns. 

1. From the Menu bar, choose: 
Format > Columns 

2. The Format Columns
box will appear 
(Figure 2.9).

3. In the Columns field,
select the number of
columns desired.

4. The width of each
column can be
controlled individually.
To change widths,
deselect the AutoWidth
button, and manually set
the width (in centimeters) of each column.

5. To place a line between the columns, choose the line width from the Line dropdown box
in the Separator line section, which defaults to None. 

6. Click OK when done.
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Spellcheck and AutoSpellcheck

StarOffice™ Writer includes tools that make proofreading your document easier using the
Spellcheck and AutoSpellcheck functions.

Spellcheck

1. From the Menu bar, choose: 
Tools > Spellcheck > Check

TIP

The Spellcheck button on the Main toolbar will also initiate Spellcheck.

2. If the Spellcheck dialog window asks to continue checking from the beginning of the
document, click Yes.

3. Spellcheck will “flag”
each word  it does not
recognize as a valid
word. If it is a non-
conventional word that is
spelled correctly or as
you desire it to be
spelled, click the Ignore
button. Otherwise, click
the Replace button, and
Spellcheck will replace
the word with the
highlighted suggestion
from the Suggestions
box. See Figure 2.10.

4. Spellcheck will continue
searching the document each time you ignore or replace a word or until you manually
stop the check by pressing the close button. Once Spellcheck cannot find anymore
incorrectly spelled words, it will notify you that the check is complete.
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AutoSpellcheck

AutoSpellcheck operates as you type your document. If you type a word that is not in the
dictionary, it will underline the word with a wavy red line. This way, you can tell at a
glance which words may be incorrectly spelled, and correct them yourself as you type.

1. To turn on the AutoSpellcheck feature, from the Menu bar choose: 
Tools > Spellcheck > AutoSpellcheck. 

TIP

The  AutoSpellcheck  button on the Main toolbar will turn the
AutoSpellcheck function on and off.

PRACTICE

• Create two pages of text. (You can cut and paste one sentence
or paragraph multiple times to save typing time.)

• Turn AutoSpellcheck on then off to experience how this works
while typing.

• Insert headers and footers for the document.

• Practice establishing columns, varying the number and width,
using the line separator.

• Spell check the document.
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Using Objects in Documents

Working with Tables

Tables can be used to present data in a more organized fashion. A table
displays information in rows and columns. For example, a table would be
used to prepare a list of items with multiple fields of information, such as
title, supplier, and price.

Inserting a Table

1. Place the cursor at the position in the text where you want to insert the
table.

2. Click on the Insert icon, the top button on the Main toolbar. (If it doesn't
look like the icon displayed in Figure 2.11, click and hold down the button
to display a menu from which you can choose the Insert Table option.)

3. In the Insert Table dialog box, specify the appropriate table details, such as the number
of rows and columns. (You do not have to give the table a name, but it helps in
organizing your document for advanced uses of Writer.) 

                                                                                                                      Figure 2.12

4. Click the OK button to insert your table.
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TIP

New tables are pre-formatted. The first row will have the Paragraph Style
"Table Heading," and other rows will have the "Table Contents" Style. Text
entered in the first row will automatically be bold and centered. 

To change table formatting attributes:

1.Click in the table.

2.Choose Format > Table.

Deleting Tables

To delete a whole table from your text document, you have the following options:

1. Select from the end of the paragraph before the table to the start of the paragraph after
the table. 

2. Press either the Delete or Backspace key.

OR 

1. Place the cursor in the table.

2. Select all cells (Ctrl+A).

3. Open the context menu (right click) and select Row > Delete. 

PRACTICE

• Practice inserting tables with various rows and columns.

• In at least one table, play with the format settings, e.g. table
background, text color, etc.

• Insert a table and delete the whole table.
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Inserting Graphics From the Gallery

Inserting graphical objects into your document can add clarity to your content as well as
enhance the document's appearance. 

The Gallery contains many graphics in directories ordered according to themes. You can
drag a graphic from the Gallery into a text, spreadsheet or presentation document. 

1. Choose Tools > Gallery, or click the Gallery icon on the
Function bar (Figure 2.13).

2. The Gallery will display as shown in Figure 2.14. The Themes
are shown on the left and a preview of each graphic is shown
on the right.

3. Click and drag a Gallery graphic into your text document
(Figure 2.14). 

4. In the next section, you'll learn how to wrap text around an image or gallery graphic.
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Inserting Images and Charts

Images supplement the text and can make the document look more professional, and a chart
can graphically represent data you are presenting.

Images

1. Click on the Insert icon (top button in the Main toolbar) and hold down for a long-
click. A menu of options will appear. 

2. Click on the icon that
reads Insert Graphics
when you move your
mouse over it.

3. Navigate through your
directories (Figure 2.15),
and select a graphic file
to insert into your
document.

4. To insert your image,
click the Open button.

5. Finally, select and move
your image to the desired
location in your
document.

Charts

To create a chart, you must first place the data you wish to represent in a
table. Once you have your data, follow the steps below.

1. Use your mouse to highlight the cells in the table that contain the data,
including headings, if they exist.

2. Click on the Insert Objects icon, which is the third button on the Main
toolbar. If it doesn't look like the icon displayed in Figure 2.16, click
and hold down the button to display a menu from which you can choose
the Insert Chart option.

3. Your cells should already be represented in the first AutoFormat step. Click the Next
button to continue.

4. Select the chart type in the AutoFormat Chart box, as shown in Figure 2.17.

5. Click the Next button to continue. 
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6. Choose a variant type.
This will change the way in
which your data is being
displayed within the chart
type you selected. (Note
that you can preview in the
box on the left.) When you
are satisfied, click Next to
continue.

7. Fill in the chart title, as
well as the titles for your
axes. 

8. Click the Create button
when finished.

9. Finally, use your mouse to select and position your chart in your document.

Wrapping Text Around an Object

Text near an object, such as a
graphic, image or chart, will show
only on the lines above and below
the object by default. To make the
text flow, you'll need to wrap the
text around the object.

1. Select the image with your
mouse (click once). The green
selection handles will appear as
shown in Figure 2.18.

2. Right click on the object to
access the context menu. 

3. Choose Wrap > Page Wrap.

PRACTICE

• Practice inserting graphics from the Gallery.

• Practice inserting images into a document.

• Play with the varying options for positioning the graphic within
text and wrapping the text around the image.
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Using Templates

A template contains the Styles for uniform design of your document, optional text, frames,
buttons, etc. It is essentially a predefined and preformatted file.

1. Begin a new document from a “templated” layout:
File > New > Templates and Documents

2. The Template setup
window appears, as shown
in Figure 2.19. In the center
window, you will see a
variety of template
categories. (Double-clicking
on one of the categories will
list the types of templates
available in that category,
e.g. Business
Correspondence, Education,
etc.)

3. Click on a template to view
information about it in the
window on the right.

4. Choose a template then click
Open. 

TIP

The document opens with a distinct format already established, sometimes
with information stored on your computer already “plugged in.”

Some templates even have fields inserted that allow you to address your
document to multiple recipients based upon an address database.

PRACTICE

• Experiment with various StarOffice™ Writer templates and
saving the file for later use.
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Printing a Document

When printing a document in StarOffice Writer™, you can use the default print options or
change the default options, including the number of copies and the print range. 

1. To use the default
options, click the 
Print icon on the
Function bar. 

2. Alternatively, to change
the printing options,
choose File > Print.

3. In the resulting Print box
(Figure 2.20), you can
modify default options
such as page range,
number of copies, and the
printer to use.

Page Preview

To view how the document will appear prior to printing, you may preview the page(s).

1. Choose File > Page Preview
This selection allows you to activate and deactivate the page preview of the document. 

2. Page View Object Bar contains icons for paging through multiple page documents or
for simultaneous viewing of several pages.

3. To close the Page Preview window, once again choose File > Page Preview.

Create Your Own

The Open Gateways Curriculum for Teachers Web site provides opportunity to reinforce
the material delivered in this Module. Download the "Create Your Own" document from:
www.sun.com/aboutsun/comm_invest/ogp/training/ 
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