
Open Gateways Curriculum
for Teachers 4

Module 4: Using StarOffice™ 6.0 Draw
Module 4 presents an overview of the StarOffice™ 6.0 Draw application. This feature of
StarOffice™ enables users to create images that transcend the barriers of language,
enabling self-expression or visual representation of ideas. 
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Learning Outcomes

Upon completion of this module, you should be able to:

• Distinguish between bitmapped and vector graphics

• Navigate through the StarOffice™ Draw interface

• Insert a graphic into a  StarOffice™ Draw
document

• Create shapes, lines, and segments

• Apply colors and textures

• Change the alignment and arrangement of objects

• Work with layers

• Insert a StarOffice™ Draw object into another
StarOffice™ document

PRACTICE

• Practice exercises are included at the end of key sections to
reinforce the concepts and to provide hands-on practice.

• Practice exercises require no more than 2-4 minutes.
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Overview of StarOffice™ 6.0 Draw

The StarOffice™ 6.0 Draw program can be used to create graphics of varying complexity,
such as buttons, icons, and even 3-D images. You can add color and texture and textual
labels. These features can be used to design technical schematics and organizational charts,
or simply create graphics to spice up your document.

Graphic Types

There are two types of graphics that can be
created and edited using StarOffice™
Draw: 

• Vector 

• Bitmapped

Vector
Vector images, also known as object-oriented images, are essentially “draw images”.
Vector images are named for the vectors, or mathematical objects that define lines and
curves, that compose them. You can easily resize vector images within a drawing program
like StarOffice™ Draw without sacrificing image quality. Vector images can be generated
in StarOffice™ Draw using geometry tools like the Square and Ellipse tool.

Bitmapped
Bitmapped images, or raster images, are made of small boxes called “pixels” that when
joined together like a mosaic of colors that form the final images. A scanned photograph is
a bitmapped image. StarOffice™ Draw allows you to import bitmapped images and edit
them.

Creating a New Drawing

1. If StarOffice™ is not launched, select StarOffice > Drawing from your Solaris CDE
Front Panel or your Windows Start Menu.

OR

2. To open a new StarOffice™ Calc Draw document from within any StarOffice™
document, from the Menu bar choose File > New > Drawing.

You will start your Draw exploration by first learning how to manipulate a bitmapped
graphic and then how to create a vector graphic object or group of objects.
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Working with Bitmapped Graphics

Inserting

1. From the Menu bar, choose Insert > Graphics.

Figure 4.1

2. A dialog box will appear (Figure 4.1) to allow you to search your hierarchy (file
directory) for images. 

3. Click on the Preview box to view the images. 

4. Click on the image you want to insert, and click Open.

5. Your image will be inserted into the Draw document, highlighted with green squares.
Use your mouse to position the image to the desired location.
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Editing

There are a number of basic things you can do to edit a bitmapped image once it is in a
document. 

1. To edit, you must first select the image. Click once on the image to highlight it. 
(Again, the little green selection handles appear around the image border.)

Scale
1. To change image size (scale), move your mouse over one of the green selection handles,

then click and drag until the desired size is reached. 
2. To scale proportionately, hold the Shift key down as you drag the mouse.

TIP 

Increasing the size of a bitmapped image will lower image quality. You will
see the little color pixels that form the mosaic that make up the image, often
an undesirable result. This is called “pixelization.”

Rotate
1. Click on the Effects icon in the Main toolbar, which runs down the left side

of your screen. It should default to the Rotate tool as shown in Figure 4.2 .
If it doesn't, long-click (click and hold for a moment) to view the Effects
menu, then choose the icon that reads Rotate as you move your mouse over
it.

2. The selected image should be highlighted with red circles. Click on one of
the red circles, and drag to rotate the image.

Flip
1. To flip an image, highlight it (click once) and right click. 

2. In the context menu that pops up, move your mouse over Flip. 
3. Choose to invert the image either horizontally or vertically.
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Figure 4.2



Saving

Draw documents may be saved as  StarOffice™ 6.0 or earlier versions.

1. To save a new Drawing document, choose: File > Save As. The Save As window and
file hierarchy will vary with your operating system. (Refer to Module 1: Lesson for a
refresher on saving files, if necessary.)

2. Click in the File Name  field to give it a name. 

3. Click on the arrow next to the Save
as Type field to see a list similar to
the one in Figure 4.3. This allows
you to save your file in formats
that are compatible with earlier
versions of StarOffice™ Draw. Do
not accept another file type at this
point.

4. By default, StarOffice™ will give
it the file .sxd file extension,
indicating it is a StarOffice™ 6.0 Drawing document. Click Save to accept the default.

5. Now you can save changes to your document by pressing Ctrl+S on your keyboard or
choosing File > Save from the Menu bar.

Exporting

ATTENTION

Take special note of the exporting process! StarOffice™ Drawing files must
be exported to a universal format prior to being imported into other programs
and HTML files. 

1. To export a StarOffice™ Draw file to a different kind of graphic file, such as a Web-
ready .jpg or.gif file, highlight (click once on) the image object you want to export.

2. Choose File > Export from the Menu bar. A dialog box will appear that will allow you
to choose the target directory to save your exported file.

3. Enter the name of the file you wish to export in the File Name field. Check the
Automatic file name extension box and the Selection box.

4. Pull down the Save as Type dropdown box, and choose the type of graphic file for
exporting.

5. Click the Save button to create your new graphic file.
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     Figure 4.3



PRACTICE

• Open a bitmapped graphic from the Gallery and practice
scaling and rotating.

• Export the graphic as a JPG to your work directory.

Creating Vector Graphics and Objects

Constructing Shapes

StarOffice™ Draw allows you to create a variety of shapes easily and
efficiently, using a simple click-and-drag interface.

1. On the Main toolbar, locate the two icons that represent a Rectangle and an
Ellipse. Their locations are marked shown in Figure 4.4.

2. Choose one of the shape icons and long-click. A menu will appear that shows
the different options available for that shape. 

TIP

The default option for these icons are filled shapes. Each shape has
an icon for an empty, outlined shape. You can also choose to draw a
square or rounded rectangle instead of a rectangle or a circle instead
of an ellipse.

3. Select (single click) a version of a shape. Your cursor should now have the shape
floating to the lower right of it.

4. Click on the main canvas of your document, and drag your mouse to size your shape.
When you release your mouse button, your shape will appear on the canvas.

5. Try this a few times to experiment.
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Figure 4.4



Drawing Sectors & Segments

As mentioned above, long-clicking on the shape icons will allow you to see a menu of
variations for that shape. Long-clicking on the Ellipse icon will see a variety of partial
shapes. These icons will allow you to draw sectors and segments, which are useful in
creating chart and graph visuals.

1. Long-click on the Ellipse icon; 
choose Ellipse Pie > Unfilled, as shown in Figure 4.5.

2. Click on the main canvas of your document while
holding the mouse button down, and drag the shape of
the ellipse, off the segment from which the ellipse will
be based.

3. When you release the mouse, note that a radius now
appears that follows the movement of the mouse.
Position the radius of the mouse where you would like
one boundary of the segment to be placed, and click once.

4. As you move the mouse, a second boundary will follow and divide the ellipse into a
segment. Move your mouse until you create the desired shape, and click once to create
the sector. (This can be tricky.)

5. The rest of these tools operate in a similar fashion, allowing you to create circle
segments, filled sectors, and more. Briefly explore the options.

PRACTICE

• Explore the types of vector objects you can create by drawing a
variety onto your Draw canvas.
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Figure 4.5



Editing Colors and Textures

Colors

Once you have created a few shapes and placed them on your canvas, the next step is to
choose their colors.

1. You should see a bar at the bottom of your screen, which contains your color palette
(Figure 4.6). If you don't, choose View > Toolbars > Color Bar from the Menu bar.

                                                                                                                                             Figure 4.6

2. Select a shape on your canvas (single click). 

3. Select a color on the color bar, to change the shape to the selected color. This is known
as the “fill” color.

4. To change the color of the outline, highlight the object; select the desired color from the
first color dropdown menu in the Object toolbar at the top of your canvas as shown in
Figure 4.7.

                                                                                                                              Figure 4.7

TIP

The second dropdown menu next to the paint bucket will also change the fill
color of your objects.

Textures
Instead of assigning a color to an object, you can
apply a texture, such as cross-hatching or a color
gradient. The texture tools are in the Object toolbar
at the top of your canvas, Figure 4.8.
1. Choose the type of texture from the first dropdown menu.
2. Choose from the list of textures available for that type. 
3. To apply a drop shadow to the shape, click on the small box at the right.
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 Figure 4.8



Rotating Objects

Shape objects can be scaled and rotated similar to bitmapped objects. Refer to bitmapped
objects for a refresher on scaling and rotation. The tools are the same.

PRACTICE

• Apply color and texture to object shapes.

• Rotate and scale the shapes to become comfortable with the
tools.

Creating Lines and Arrows

Lines are created in StarOffice™ Draw the same as shapes. 

1. Locate the Lines and Arrows icon in the Object toolbar, Figure 4.9.

2. Long-click on this icon to display a floating menu that contains the
different lines and arrows you can create.

3. Select the line of your Your cursor should now have the line floating to the
lower right of it. 

4. Click on the main canvas of your document, and drag the mouse to “size”
your line. Release the mouse button to create it.

5. To change the positioning of your line, highlight it so that the turquoise endpoints are
displayed. Drag one of these endpoint to rotate your line to the desired position.

6. To change the color of a line, highlight it and select a color from the first color
dropdown box  in the menu at the top of your canvas.
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Figure 4.9



Creating 3D Objects

1. Long click the 3D Objects icon in the Object toolbar, Figure 4.10.

2. A menu of 3D objects appears. Select the one you wish to draw, and drag
your cursor over the main canvas of the screen.

Creating and editing 3D objects this way is identical to the steps you took to
create a regular shape. 

3. Try changing the color and scale of your 3D objects.

Converting

You can also create a 3D object by converting one your regular shapes. This
will stretch your shape across the Z axis to create a three-dimensional image.

1. Highlight one of your existing shapes or draw a new rectangle or ellipse.

2. From the Menu bar, choose: Modify > Convert > To 3D.

3. Your shape is now a 3D object. Alternatively, you can highlight a shape and choose
Modify > Convert > To 3D Rotation Object to stretch your shape around a vertical 3D
axis, like a globe.

PRACTICE

• Practice creating lines and arrows.

• Create and color one or two new 3D objects.

• Convert an existing, 2D shape to a 3D object.

ADVANCED: Cross-Fading Between Two Objects

The process of cross-fading is a transition in increments between two objects. The
increments created by the cross-fading, the orientation, color, and other attributes are
adjusted uniformly.

1. Draw a rectangle in the bottom left and a circle in the upper right. Use two colors.

2. Select both objects. (Click on one, and hold down the Shift key while clicking on the
other.)

3. From the Menu bar, choose: Edit > Cross-fading. A dialog box appears to define
further settings. Select how many increments you want the transition to take by setting
the number in the Increments field.

4. When you click OK, the two shapes on your canvas will be connected by a series of
transitional images.
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Arranging, Aligning, and Grouping Objects

When you have multiple objects on your canvas, it will become necessary to change the
way your images are composed or arranged. 

• “Arranging” refers to how objects are displayed in front of other objects or
how they are overlapped. 

• “Alignment” refers to where on the canvas an image displays. 

• “Grouping” is a way to associate one object with another.

Arranging

1. Create two separate shapes, and place
one over the other so that they
overlap.

2. Highlight the image object on top and
right click. From the menu that pops
up, choose Arrange > Send
Backward.

3. The image now displays behind the other.

Take note of all of the Arrangement options that are available. 

• Bring Forward places the image one step in front. 

• Send Backward places it one step behind. 

• Bring to Front places it in front of all other images, and Send to Back sends it behind
all other images.

Aligning

1. Select an image object, and right click.
From the menu that appears, mouse over
Alignment.

2. The options that are displayed allow you
to place your image within 9 quadrants on the canvas. Choose to align your object left,
center, or right horizontally, and top, center, or bottom vertically.
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Grouping

1. Create two objects, and select both of
them. Do this by highlighting one, and
then holding the Shift key down and
clicking on the other.

2. From the Menu bar, choose:
Modify > Group
This will associate the objects as one object. 

3. Select the group, and move both objects at the same time. 

Note that position of the objects will remain relative, since they are
“grouped” together. Also, any color, texture, scale, or rotation changes you
perform will affect both of them. They are, for all intents and purposes, now
treated as one image object.

4. To ungroup grouped objects, select the object group, and choose:
Modify > Ungroup

Working with Text

You are able to enter text into your StarOffice™ Draw document, either
standalone or associated with an image object.

1. Locate the Text icon is in the Object toolbar, Figure 4.13 .

2. Click the Text icon. To insert a text box  in your document., click on your
canvas and drag. Once the text box is placed, you can start typing your text.

3. To associate text with an object, highlight the desired object and then click
the Text icon. The text box is placed on the object and is considered part of
that object's group.

4. To change the font and format of your text, make sure the Text icon is
selected. Use the formatting bar that appears at the top of your canvas.
Modify your text as desired.

5. To change the alignment of the text on an image, select the image and right click. From
the menu, select Text. A window is displayed that allows you to select a radio button
that represents where in the image frame the text will be aligned.
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Using Layers

Drawing and Presentation documents have different layers, some of which can be hidden,
prevented from printing or safeguarded against further editing. The layers are transparent.
This means that you can always see all the layers on each slide. You can make each
individual layer invisible, and hide it from view.

Working with layers is like putting your objects on top of each other on transparent
overhead sheets. Essentially, layers provide a more organized way to arrange canvases with
multiple objects.

TIP

Every slide of your drawing can contain several layers, which in turn contain
various objects. 

In slide presentations, each layer always appears on all slides. The
background can also contain several layers.

Inserting a New Layer

1. Switch to the Layer View by choosing View > Layer from the Menu bar.

2. Select Insert > Layer from the Menu bar.

3. This opens the Insert Layer dialog. Give the new layer a name. At the same time,
decide whether the layer should be Visible, Printable or Locked. For now, choose
Visible.

4. Click OK. The new layer automatically becomes the active layer, and all objects now
appear on the new layer.

Moving Objects Between Layers

To move an object from one level to another, simply select the object and drag it to the tab
on the other level.

PRACTICE

• Insert a New Layer into your Drawing document.

• Experiment with adding objects to the layers.
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Inserting Objects into StarOffice Documents

Moving and Copying

You are able to copy image objects and insert them into new StarOffice™ documents,
including other types of documents such as Writer files. 

1. Select (right click) the desired image.

2. Select Edit > Copy from the Menu bar.  

3. Open up the document into which you desire to place a copy of the image object.

4. Select Edit > Paste.

Create Your Own

The Open Gateways Curriculum for Teachers Web site provides opportunity to reinforce
the material delivered in this Module. Download the "Create Your Own" document from:
www.sun.com/aboutsun/comm_invest/ogp/training/ 

Open Gateways Curriculum for Teachers                                                               p. 15 of 15
Module 4: Using StarOffice™ 6.0 Draw                                                                    
Copyright 2002 Sun Microsystems, Inc. All rights reserved.


