
Open Gateways Curriculum
for Teachers 5

Module 5: Presentations with StarOffice™ 6.0 Impress
Users can take advantage of StarOffice™ Impress templates to create professional-looking
presentations that can communicate ideas in small or large groups. A supplemental style
guide gives tips on how the use of color, fonts, and text can be used to produce effective
presentations. Presentations, when supported by visual materials, enhance an audience's
ability to focus, recall key points of a lecture, and understand topic to a deeper level. 

Index

Learning Outcomes......................................................................................................2

Overview of StarOffice™ 6.0 Impress............................................................................3

Using the AutoPilot - Overview.......................................................................................3

Creating a Presentation................................................................................................4

Getting Started............................................................................................................4

Presentation from Template...........................................................................................4

Empty Presentation.......................................................................................................6

Customizing a Presentation...........................................................................................7

Adding a Slide............................................................................................................7

Modifying Layout.........................................................................................................8

Arranging Slides..........................................................................................................8

ADVANCED: Master Slides...........................................................................................9

Using Various Views...................................................................................................10

Adding Elements to Your Slides...................................................................................12

Importing Image Objects.............................................................................................12

Showing a Presentation..............................................................................................13

Printing a Presentation................................................................................................14

Importing & Exporting.................................................................................................15

Create Your Own.......................................................................................................15

Open Gateways Curriculum for Teachers p. 1 of 15
Module 5: Presentations with StarOffice™ 6.0 Impress
Copyright 2002 Sun Microsystems, Inc. All rights reserved.



Learning Outcomes

Upon completion of this module, you should be able to:

• Create a StarOffice™ Impress presentation,
either blank or templated, via the AutoPilot
Presentation Wizard

• Save a presentation, in different file formats

• Be able to use Drawing view, Outline view,
Slide view, Notes view, and Handout view

• Format and arrange slides in a presentation

• Modify Slide Layout

• Print a presentation

• Import image objects into a presentation

• Run and show a presentation

• Export a presentation to various file formats

PRACTICE

• Practice exercises are included at the end of key sections to
reinforce the concepts and to provide hands-on practice.

• Practice exercises require no more than 2-4 minutes.
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Overview of StarOffice™ 6.0 Impress

Presentations and slide shows are effective tools for educational communication. With
StarOffice™ Impress, you can create presentations that can present class work for back to
school night, research projects, etc. Impress provides various tools to create attractive and
functional presentations from scratch or based off existing templates.

Using the AutoPilot - Overview

The AutoPilot Presentation automatically guides you through each step of the process to
create and customize a presentation.

The first screen presents the following three choices to specify the presentation type and/or
select a template (Figure 5.1).

• Empty presentation
This will create a presentation containing a blank slide without any styles.

• From template
This allows you to choose and customize a predesigned template for your presentation,
which will be applied to the slides by default.

• Open existing presentation
This will prompt you to open a previously saved presentation.
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TIP

AutoPilot starts automatically if you open a new presentation with 
File > New. You can deactivate this option on the first page of the AutoPilot
by marking the Do not show this dialog again check box. You can also
deactivate this function from Tools > Options > Presentation > General,
and uncheck the Start with AutoPilot check box.

Creating a Presentation

You are first going to create a presentation from a template and then an empty presentation.
Both types of presentations have their advantages. A presentation from template does a
lot of the work for you, providing you with a visual theme and organizing both the slides in
your presentation and the information presented in each slide. However, an empty
presentation gives you more control to customize the presentation.

Getting Started

1. If StarOffice™ is not launched, select StarOffice > Presentation from your Solaris
CDE Front Panel or your Windows Start Menu.

OR

2. To open a new StarOffice™ Impress presentation file from within any StarOffice™
document, from the Menu bar choose File > New > Presentation.

3. The AutoPilot Presentation will automatically appear.

Presentation from Template

1. Screen 1: In the AutoPilot Presentation dialog box,
choose: From template

2. Screen 1 (cont.): A Presentations menu appears
once you check the From template option.

• Select a template category. 

• Select Preview to see a sample. 

• Click Next>> to continue.

3. Screen 2: Select a slide design from the Presentation Backgrounds dropdown menu in
the upper left. Preview the backgrounds and data organization for samples.

• Check Preview to see samples.

• Check the Screen option underneath Select an output medium.
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• When finished, click the Next>> button.

4. Screen 3: Select a slide transition. This will change the way that one slide moves into
the next.

• From Effect, choose the desired effect from the dropdown menu.

• From Speed, choose Slow, Medium or Fast for the speed between slides.

• Under Select the presentation type, keep the Default option selected to create a
presentation that is manually controlled (by mouse or keyboard). 

• When finished, click the Create button to customize your presentation.

5. Screen 4: Define the basic ideas of your presentation in the dialog boxes. This
information will automatically be entered into your slides.

• Company Name

• Subject of Presentation

• Further Ideas, etc. 

• Click Next>> to continue.

6. Screen 5: Preformatted pages are automatically created for your selected template.
These are displayed in the left window as shown in Figure 5.2.

• Browse and preview the available pages.

• Select those that apply to your presentation by checking the small page icon next to
each page.
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• When finished, click the Create button to customize your presentation.

PRACTICE

• Experiment with creating a presentation from a Template. Do
not spend too much time on this option.

Empty Presentation

1. Create a new presentation document: 
File > New > Presentation

2. Screen 1: Choose Empty Presentation, 
and click the Next>> button.

3. Screen 2: Select a slide design from the
Presentation Backgrounds dropdown menu in
the upper left. Preview the backgrounds and data
organization for samples. 

• Check Preview to see samples.

• Check the Screen option underneath Select an output medium.

• When finished, click the Next>> button.

4. Screen 3: Select a slide transition. 
This will change the way that one slide moves into the next.

• From Effect, choose the desired effect from the dropdown menu.

• From Speed, choose Slow, Medium or Fast for the transition speed between slides.

• Under Select the presentation type, keep the Default option selected to create a
presentation that is manually controlled (by mouse or keyboard). 

• When finished, click the Create button to customize your presentation.

TIP

The Automatic option enables you to set a time interval for the slides to
transition on their own. (The Automatic feature is especially useful for an
“open house” or back-to-school night.)

5. At this point, keep your document open to customize your presentation. 
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Customizing a Presentation
The following steps apply to either type of presentation, Empty or Template.

Adding a Slide

When you create a new presentation, you should see a floating
box like the one shown in Figure 5.3.

1. To insert a new slide, click Insert Slide.

If this box does not appear on your screen or if you do not
desire to have this window open, you can insert a new
slide by choosing Insert > Slide from the Menu bar. 

2. When you add a slide, you are automatically prompted to establish the slide layout. 
The AutoLayout box will appear as shown in Figure 5.4.

3. Name your slide, and
choose from the list of
AutoLayouts to arrange a
slide's content area. 

4. Move your mouse over
each graphical
representation to see a
yellow box explaining
each slide's content(s)
layouts, e.g. Title Slide,
Text, Clipart, Spreadsheet.

5. Once you add a slide,
simply click a labeled area
to add titles, text, clipart,
etc.

6. To use the Clipart layout
to add images, double
click and then navigate
your file hierarchy to
locate your desired image.
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TIP 

Make sure that both the Background and Objects on Background boxes are
checked underneath Display to ensure your visual template is on each slide.

Modifying Layout
1. To change the layout, return to the AutoLayout box then do one of the following:

• Choose Format > Modify Layout from the Menu bar.

• Right-click the slide and choose Slide > Modify Slide from the menu that appears.

Arranging Slides

1. Arrange the content elements of each individual slide by clicking and dragging an object
to the desired position on the screen.

2. There are two simple ways to change the slide order. Use one of the following:

• Each slide is represented by a “tab” located at the bottom of the screen as shown in
Figure 5.5. To move a slide, click the tab and drag it horizontally to a new position. 

• Use the Slides View (View > Master View > Slides View) to arrange slides by
clicking and dragging. This feature is covered in Using Various Views, p11.
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ADVANCED: Master Slides

StarOffice™ Impress creates a consistent appearance for the presentations. Master slides
contain information that will
appear on all slides. 

Formatting the master helps
unify the entire presentation
and make easy changes to a
presentation without having to
modify every slide.

To modify the Master Slides:
1. Choose View > Master

from the Menu bar. 
2. Move your mouse over the

Master option to see the
context menu which offers
following four Master
Slides to edit as outlined on
the next page.

Drawing
The Drawing master contains the layout for all slides in the presentation, as shown in
Figure 5.6. 

• The format of the presentation title, bulleted-list text, and the placement
of objects are determined by the settings in this Drawing master.

Title
The Title master is similar to the Drawing master but applies only to the
formatting of  each slide's title.

Notes
The Notes master is used to modify the format of the speaker notes. In
addition, you use the Notes master to insert all text and images for all the
notes.

Handout
The Handout master is used to modify the layout of the printed handouts and
to change the position of the slides in the handouts.

Returning to Slides

1. To exit the Master slide view and return to your presentation, choose 
View > Slide from the Menu bar.
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PRACTICE

• Practice adding a slide and then modifying layout of objects by
clicking and dragging.

• Optional: If time permits, work with modifying the Master
Slides.

Using Various Views

StarOffice™ Impress offers four views to help you organize content and customize
presentations. 

• Drawing

• Outline

• Slides View

• Notes

• Handout

The following is an overview of the views. 

1. Explore after reading each explanation.

2. To change views, choose from the Menu bar:
View > Master View

Drawing View

Drawing view is displayed by default when you create a presentation. You insert slides and
objects, such as graphics, animations, and charts. In addition, you can modify existing
slides. This is essentially the “working” view.

Outline View

Outline view is helpful to develop and organize the content of a presentation. You can also
use this view to create the framework and to rearrange the structure of your presentation.

• The title of each slide is arranged with the slide's text in sequential order down the page
in Outline view. This is a convenient way to view the entirety of your presentation's
content and allows you to change any title or content area.

1. To add a new slide in Outline view:

• Click on an existing slide.
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• Press the Enter key. 

2. A new slide will be added directly after the current slide.

3. Arrange the slides' order by clicking on one of the slide icons on the left side of the page
and dragging it to the desired position.

Slides View

Slides view displays the slides in a matrix as thumbnails. This is a graphical representation
of the Outline view.

This view presents an easy format to insert, copy, rearrange, and delete slides.

You can also change the slide transition for each slide using the custom toolbar at the top of
the screen, shown in Figure 5.7.

Figure 5.7

Select a slide or series of slides prior to applying formatting.

Notes View

Notes view is used to add speaker notes and other “behind the scenes” information. These
notes will not display as a part of your presentation to the audience.

It's interface is similar to that of the Drawing view, allowing you to associate separate notes
and images to each individual slide.

Handout View

To print more than one slide on a page, you utilize the Handout view. Note that you can
print only groups of consecutive slides on one page. You can also modify the position and
size of slides on a printed handout page using Handout view.

PRACTICE

• Experiment with the different views as you create your
presentation. 

• Add, delete and arrange slides.

• Determine which ones make it easiest for you to customize your
presentation.
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Adding Elements to Your Slides

There are a few ways to put graphics in your
presentation. You can import image objects
created and exported in StarOffice™ Draw, from
the Gallery, the Web, or from another document.
Also, StarOffice™ Impress includes drawing
tools that allow you to create new image objects
directly in your presentation. (Module 2 presents
how to insert  images from the Gallery or from a
file, and Module 4 shows how to create images
from scratch.)

Importing Image Objects

1. Navigate to the slide into which you want to
insert your image

2. Choose Insert > Graphics from the Menu bar.

3. Choose the graphic you wish to insert, and click the Open button.

OR

1. Insert a new slide.

2. Choose an AutoLayout that includes a placeholder for Clipart. 

3. Click on the Clipart graphic to import an object. (See p7 of this module for reference.)

You can move, scale, rotate, and format your image using the mouse and the tools in the
Main toolbar, which operate just as they do in StarOffice™ Draw. (See Module 4 for a
refresher of these tools, if necessary.)

PRACTICE

• Practice adding an image, clipart, or an item created in Draw
into a slide.

• Optional: Experiment with the drawing tools on the Main
toolbar to create a graphic directly in your presentation.
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Showing a Presentation

Running a Presentation

By default, the presentation runs in the standard full-screen mode. After the last slide in the
presentation is displayed, a black screen appears to indicate the end of the presentation.

To view the completed slide show presentation, do one of the following:

1. From the Menu bar, choose: 
Slide Show > Slide Show

2. To advance manually one slide at a time, click the mouse or press the spacebar, the
Enter key, or right arrow key on your keyboard. (The left arrow will step you through
the slides in reverse order.)

OR

1. Click the Slide Show icon (Figure 5.8), located at the bottom of the Main
toolbar.

2. Use the same options shown above for advancing through the slides if you
do not have your presentation set to run itself.

Closing a Presentation

To close the presentation and return to the StarOffice™ Impress interface:

1. Press the Esc key.

2. This will return you to your working mode.

TIP 

Before running your presentation, you can preview each slide by opening the
Preview box. This box usually opens by default in most of the views, but if it
does not appear, open it by choosing View > Preview from the Menu bar.

• With this box open, you can make corrections to your slides and view the
effect in the presentation simultaneously.
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Printing a Presentation

1. Select File > Print from the Menu bar. 

2. This will open the Print dialog box.

3. Click the Options button to open the Printer Options box shown in Figure 5.9.

4. Select the options you wish to apply to your print job. 

• Under Contents, you can change the view you want to print out. 

• Drawing prints out the presentation as it appears in drawing mode. 

• Notes will print the speaker notes that you have prepared for each slide. 

• Handouts, as mentioned before, allows you to print more than one slide per page, and
“Outline will print the condensed outline of your presentation. 

• Below that, you can choose to print identifying information on each slide under Print.
Make sure the Default options are selected on the two lists at the left, and click the
“OK” button.

5. Click the OK button in the Print dialog box to print your presentation.
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Importing & Exporting

File Formats

StarOffice™ Impress also allows you to import a
variety of different files to include in your
presentation or as a template.

1. Select File > Open from the Menu bar. 

2. In the Open dialog box, pull down the
Files of Type pulldown menu
as shown in Figure 5.10.

3. Choose a type of document for import or to use as a template. 

• You are able to import any type of StarOffice™ document, such as a Draw
or Writer file. 

• You are also able to import a presentation from Microsoft PowerPoint and
any other type of document from the Microsoft Office Suite.

Saving as HTML

To display your presentation in a Web browser, save it as an HTML Web page.

1. From the Menu bar, choose: File > Export. 

2. In the Export dialog box, the pulldown menu at the bottom labeled Save as Type should
say “Web Page.” If it doesn't, pull down the menu, and select the Web Page option.

3. Click the Save button to save your presentation as an HTML-based Web page.

Saving as Other Formats

You can save your presentation in multiple formats under File > Save As.

1. When the Save As dialog box appears, pull down the Save as Type box, similar to the
process described above for opening different file formats, including Microsoft
PowerPoint or earlier versions of StarOffice™ Impress.

Create Your Own

The Open Gateways Curriculum for Teachers Web site provides opportunity to reinforce
the material delivered in this Module. Download the "Create Your Own" document from:
www.sun.com/aboutsun/comm_invest/ogp/training/ 
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