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Chapter 1

 

Introduction

 

The Sun™ Management Center server layer is the heart of the Sun Management Center application. 

It maintains persistent data critical to the operation of the overall product. Special care must 

taken to preserve the integrity of the server data when making certain configuration changes on 

the server layer host.

This document describes how to migrate Sun Management Center server data in the 

following scenarios:

• Server software is moved to another host system with a different hostname and primary IP 

address

• Server software is moved to another host system with a different primary IP address but the 

same hostname

• The primary IP address of the server host is changed

• The size and the locations of the Performance Reporting Manager (PRM)-specific data files 

on the server are reconfigured

In all of the scenarios described in this document, the Sun Management Center server 

software version and add-ons are assumed to be unchanged before and after the configuration 

change.

For information on standard Sun Management Center upgrade procedures, please refer 

to the 

 

Sun Management Center 3.5 Installation and Configuration Guide.
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Disclaimer

 

The procedures described in this document were tested with Sun Management Center 3.5 and the 

PRM 3.5 add-on in a limited set of cases. Presently, the procedures are not officially supported for 

Sun Management Center 3.5 and may not work in earlier and future releases. Depending on 

customer feedback, future versions of Sun Management Center may support these procedures.

 

Intended Audience

 

Users intending to perform the procedures must have a working knowledge of the Solaris™ 

Operating System (OS). Users must also be familiar with installing and configuring the Sun 

Management Center software.

• Users planning to change the hostname and the IP address of the server host should be familiar 

with these system administration tasks.

• Users planning to perform the PRM reconfiguration procedure must be familiar with installing 

and configuring PRM add-on software on the server layer.

 

Typographical Conventions

 

The following typographical conventions are used in this document.

 

Overview

 

The remainder of this document is organized into the following chapters:

•

 

Background Information

 

 — Provides background information on the Sun Management Center 

software design and discusses issues relevant to preserving server data when changing the 

server configuration.

•

 

Changing the IP Address of the Server Host

 

 — Describes how to preserve server data when 

changing the primary IP address of the server host.

•

 

Migrating the Server to a Host With a Different IP Address

 

 — Describes how to migrate server 

data when moving the server to another system with a different primary IP address and the 

same hostname.

•

 

Migrating the Server to a Host With a Different Hostname and IP Address

 

 — Describes how to 

migrate server data when moving the server to another system with a different hostname and 

IP address.

•

 

Reconfiguring PRM on the Server

 

 — Describes how to preserve server data when changing PRM 

configuration size and locations of PRM data files on the server.

•

 

Validating the Server Data

 

 — Describes checks to verify that server data was preserved after 

changing the server IP address or hostname.

•

 

Summary

 

 — Summarizes information provided in this document.

•

 

References

 

 — Lists other documents related to this topic.

 

Typefaces Meaning Examples

 

AaBbCc123
The names of commands, files, and directories; 
and on-screen computer output.

Use 

 

1s -a

 

 to list all files
% You have mail.

 

AaBbCc123

 

Book titles, new works or terms, and words to 
be emphasized. Replace command-line 
variables with real names or values.

Read Chapter 1 in the 

 

User's 
Guide

 

. You 

 

must

 

 be superuser 
to do this.
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Chapter 2

 

Background Information

 

This chapter presents background information to help readers gain a better understanding of 

the issues related to preserving Sun Management Center server data when changing the server 

hostname and its primary IP address, or reconfiguring PRM on the server host. The discussion 

is organized into the following topics:

• Sun Management Center Architecture

• Server Hostname and Primary IP Address

• PRM Server Configuration

 

Sun Management Center Architecture

 

The Sun Management Center 3.5 systems management framework comprehensively manages 

all Sun systems and storage equipment in the enterprise. The Performance Reporting Manager 

(PRM) 3.5 is an add-on product that enables users to track performance data on systems managed 

by Sun Management Center and generate reports that are easily shared across the organization.



 

P
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The Sun Management Center architecture is comprised of client, server, and agent layers.

 

Figure 2-1: 

 

Sun Management Center Architecture

 

Client Layer

 

The client layer is comprised of one or more clients (Java™ technology-based graphical console, 

Web-based console, and command-line interface) that users employ when interfacing with Sun 

Management Center software.

 

Server Layer

 

The Sun Management Center server layer is composed of several Sun Management Center server 

processes running on the same host system. These processes provide many common services, 

including topology and discovery, alarm management, user security configuration, Web-based 

access, job control, trap handling, and centralized communication between Sun Management 

Center clients and agents. In addition, the server layer maintains persistent configuration and 

management data integral to the operation of the application. 

 

Agent Layer

 

The agent layer is comprised of Simple Network Management Protocol (SNMP)-based agents 

running on host systems managed by Sun Management Center. During agent setup, the agent is 

assigned to a 

 

server context

 

 by specifying the hostname of the Sun Management Center server.

A Sun Management Center server layer and one or more agents associated with the server 

define a 

 

server context

 

. Agents send all SNMP traps to their server context hosts. In turn, each 

server propagates security configuration and collects event information from all agents in its 

server context. As a result, when users log into a Sun Management Center server, they can perform 

privileged management operations (for example, load or unload management modules, edit 

alarm criteria, and so on) on the agents that belong to the current server context.

For more information about the Sun Management Center architecture, please refer to the 

technical white paper, 

 

The Architecture of Sun Management Center

 

.
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Server Hostname and Primary IP Address

 

This section highlights some of the persistent data maintained by the Sun Management Center 

server and agents that are sensitive to the server’s hostname and its primary IP address. The 

primary IP address is the one that is associated with the hostname returned by the 

 

uname -n

 

 

command.

Persistent data sensitive to changes in the server hostname and primary IP address include:

• Server context IP address specification

• SNMP configuration

• Topology and other server data

• Agent server context specification

 

Server Context IP Address Specification

 

The Sun Management Center 3.5 server layer maintains a list of one or more IP addresses that it 

is configured to include as part of its server context. While this specification is used by all Sun 

Management Center server installations, it is most pertinent when the server layer is installed 

on a system with multiple IP interfaces.

By default, the Sun Management Center server setup program initializes the server context 

specification to include the IP addresses of all network interfaces on the server system. Subsequently, 

users can use a command line utility (

 

esmultiip

 

) to list, add, or remove IP interfaces supported 

by the Sun Management Center server.

Clearly, this specification is sensitive to the server host’s IP addresses. The server IP address 

change procedures described in this document apply only when the primary IP address of the 

server is being changed. If a server’s nonprimary IP address is being modified, the procedures 

described in this document do not apply. In these cases, the user should utilize the 

 

esmultiip

 

 

command-line utility to update the Sun Management Center server IP interfaces configuration 

appropriately. For more details on the use of this utility, please refer to the 

 

Sun Management 

Center 3.5 Installation and Configuration Guide

 

.

 

SNMP Configuration

 

The SNMP engine identifiers of the SNMP-based server layer components are generated during 

Sun Management Center server setup. These engine identifiers are derived from the server’s 

primary IP address. Consequently, some of the SNMP security-related data on the Sun Management 

Center server depends on the server’s primary IP address.

 

Topology and Other Server Data

 

The server’s primary IP address can be embedded in topology data that describes the topology 

domain and group objects. This topology data can be migrated between Sun Management Center 

server layers through the topology export and import functions.

Various other server layer data that pertain directly to the server host (for example, event 

data related to the server host agent, group filters, and so on) can also have server hostname 

and IP address dependencies.



 

P
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Agent Server Context Specification

 

Each agent must be configured with the hostname of the Sun Management Center server context 

it belongs to. This server context is specified when the agent is set up. Thus, if the server's 

hostname is changed, the agents in the server context must also be reconfigured with the 

new server hostname.

 

PRM Server Configuration

 

PRM on the server layer consists of services that periodically collect performance data from 

agents as well as PRM-specific data files to store and manage the data. The PRM’s storage 

capacity and performance requirements on the server layer depend on the volume of data 

being tracked by PRM.

When the PRM add-on is installed and set up on the server layer, the user must select one of 

three possible PRM configuration sizes (small, medium, or large) that best suits the environment. 

Furthermore, the user must also specify directory locations for PRM data files. More information 

about PRM and its setup options can be found in the 

 

Sun Management Center 3.5 Performance 

Reporting Manager User’s Guide.

 

The need to reconfigure PRM can arise in several circumstances. The PRM configuration size 

of an existing installation may need to be enlarged if the configuration size is underestimated during 

initial setup. Alternatively, PRM performance can be enhanced by moving PRM data files from a 

single disk to separate disks, improving disk I/O throughput.

This document also describes how to reconfigure the size and locations of PRM-specific 

data files on a Sun Management Center 3.5 server, while also preserving existing PRM data.
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Chapter 3

 

Changing the IP Address 
of the Server Host

 

The procedure to preserve persistent Sun Management Center server data when changing the 

server’s primary IP address is described in this chapter. This procedure assumes that the Sun 

Management Center server installation remains on the same host system and that the hostname 

is not changed. The procedure also assumes that the server software version and add-ons are the 

same.

 

Note – 

 

If a nonprimary IP address of the server is being modified, the following procedure does 

not apply. In this case, the user should employ the 

 

esmultiip

 

 command-line utility to update 

the Sun Management Center server IP interfaces configuration appropriately. For more details 

on the use of this utility, please refer to the 

 

Sun Management Center 3.5 Installation and 

 

Configuration Guide

 

.

The following procedure involves many Sun Management Center software-related tasks. For 

more details on performing these tasks, refer to the 

 

Sun Management Center 3.5 User's Guide

 

.

When providing examples of the Sun Management Center software-specific commands to be 

executed (for example, 

 

/opt/SUNWsymon/sbin/es-start –A

 

), the following procedure 

assumes that the Sun Management Center software is installed in the default location (such as 

 

/opt/SUNWsymon

 

). If the software is installed in a different location, substitute the appropriate 

path.

Before starting the procedure, users should back up server data (with 

 

/opt/SUNWsymon/

sbin/es-backup

 

) to ensure that they can restore the server to its current state.



 

P
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Step 1: Export the Topology Data

 

The topology export/import functions can be used to maintain local topology domains and groups 

because the topology import operation effectively ignores the server IP address embedded in the 

topology domain and group objects.

 

Note – 

 

The topology export function in Sun Management Center 3.5 does not preserve topology 

objects that reference remote topology domains and groups. To preserve these references to remote 

topology objects, these objects must be manually recorded now so that they can be re-created 

after 

 

Step 8: Import the Topology Data

 

. For more details on performing these functions, refer to 

 

the 

 

Sun Management Center 3.5 User's Guide

 

.

To export the local topology data, perform the following steps:

 

1.

 

Log in to the server using the Sun Management Center console.

 

2.

 

From the main console window, select Tools->Export Topology to launch the Export Topology 

window.

 

3.

 

Export “All Domains” to the desired export file. Select the “overwrite” mode to ensure that only 

the current topology data is defined in the export file.

 

4.

 

The topology export file is saved on the Sun Management Center console host.

 

Step 2: Record Topology Discovery Requests

 

User-defined discovery requests are associated with topology domains. These discovery requests 

are not included in the topology export data and are not preserved when the topology domains 

are deleted. If the discovery requests need to be preserved, they must be manually noted in this 

step and restored after the topology objects are imported.

To view existing discovery requests, perform the following steps from the main console window:

 

1.

 

For each topology domain, select Tools->Discover Objects to launch the Discover Objects window.

 

2.

 

From the Discover Objects window, select each discovery request to be preserved and manually 

record the Request Details displayed in the lower pane.

 

Step 3: Delete the Topology Objects

 

After saving the topology data, the topology objects must be deleted to remove topology data 

that is dependent on the server’s current IP address.

To delete topology objects from the main Sun Management Center console, perform the 

following steps:

 

1.

 

Select File->Domain Manager to launch the Domain Manager window.

 

2.

 

Delete all topology domains.

 

Step 4: Stop the Sun Management Center Server Layer

 

When changing the server IP address and reconfiguring server security, the Sun Management 

Center server layer must not be running.

 

1.

 

Exit from all Sun Management Center consoles.

 

2.

 

Stop the server processes by executing 

 

/opt/SUNWsymon/sbin/es-stop -A 

 

as root on the 

server host.

 

3.

 

Before proceeding to the next step, ensure that all server layer processes have stopped by 

waiting for the successful completion of the 

 

es-stop

 

 command.



 

© 2003 Sun Microsystems, Inc.

 

Changing the IP Address of the Server Host

 

  

 

P

 

9

 

Step 5: Change the Primary IP Address

 

The actual procedure for changing the server’s primary IP address depends on the network 

environment (including files, Network Information Service (NIS), Domain Name Server (DNS), 

and so on).

 

1.

 

Change the primary IP address of the server.

 

Step 6: Change the Server Agent SNMP Port (Optional)

 

If the PRM add-on is installed on the server, the agent’s SNMP port on the server host must 

be modified to allow PRM to collect and display new PRM data from the server agent.

 

1.

 

To modify the agent SNMP port, execute the following command as root on the Sun Manage-

ment Center server host:

 

/opt/SUNWsymon/sbin/es-config -p agent

 

When prompted for the SNMP port, enter a new unused port number. When prompted 

for a seed, enter the same seed value specified for the server context.

 

Step 7: Update the Server’s IP Interfaces Configuration

 

The IP interfaces supported by the Sun Management Center server are maintained in a 

configuration file. This configuration can be updated to reflect the server’s new IP address 

by executing the following commands on the server host as root:

 

1.

 

Run 

 

/opt/SUNWsymon/sbin/esmultiip -l 

 

to list IP addresses supported by the 

server.

 

2.

 

Assuming that the list does not contain the new server IP address or the old IP address, update 

the server IP interfaces configuration with all IP addresses of active IP interfaces as follows:

 

rm /var/opt/SUNWsymon/cfg/multiip.dat
/opt/SUNWsymon/sbin/esmultiip

 

3.

 

If necessary, delete unwanted IP addresses from the server IP interface configuration file 

as follows:

 

/opt/SUNWsymon/sbin/esmultiip -d <IP address>

 

4.

 

Run 

 

/opt/SUNWsymon/sbin/esmultiip -l

 

 again to verify that the list of IP addresses 

supported by the Sun Management Center server is correct.

 

Step 8: Reset the Sun Management Center Server Security

 

Once the server IP address has been changed, the security configuration of the SNMP-based server 

components can be reset. This is accomplished as follows:

 

1.

 

Execute the following command as root on the server host: 

 

/opt/SUNWsymon/sbin/es-run base-usm-seed.sh –clean -s seed

 

where 

 

seed

 

 is the same security seed specified when the server was last set up. When 

prompted on whether to overwrite files, answer yes.

 

Step 9: Restart the Sun Management Center Server Layer

 

After changing the server’s IP address and resetting the security configuration, the server can be 

restarted.

 

1.

 

Restart the server layer by executing 

 

/opt/SUNWsymon/sbin/es-start –A

 

 as root on 

the server host.



 

P
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Step 10: Restart All Agents in the Server Context

 

All the agents in the server context must be restarted to ensure that their security information 

is synchronized with the Sun Management Center server. For each agent in the server context, 

restart the agent process as follows:

 

1.

 

Log in to the agent host as root.

 

2.

 

Stop the agent by executing 

 

/opt/SUNWsymon/sbin/es-stop –a.

 

3.

 

Start the agent by executing 

 

/opt/SUNWsymon/sbin/es-start –a.

Step 11: Import the Topology Data

To restore the topology domains, groups, and entities from the original configuration, the 

topology export file generated in Step 1 must be imported. The topology data is an important 

entry point for accessing agent-specific data such as data properties, alarm information, PRM 

history, and so on.

1. Login to the server via the Sun Management Center console.

2. Select Tools->Import Topology to launch the Import Topology window.

3. Import the file exported in Step 1 using the “follow” mode to preserve the original topology 

domain hierarchy. 

Step 12: Modify Server Agent Topology Data

The topology export file generated in Step 1: Export the Topology Data is accurate with the 

exception of topology entities that reference agents running on the server host. These entities can 

include the original Sun Management Center agent in the Default Domain, as well as platform 

agents running on the server host. The IP address of these server host-related entities must be 

replaced with the new server IP address. If the SNMP port of the server host’s agent was modified, 

the port number should be updated as well.

To update the IP addresses of the server host-related entities, perform the following steps 

for each affected entity:

1. From the main console window, select the topology entity to be modified.

2. Right click on the entity and select the “Modify Object” option to launch the Modify Object window.

3. In the Modify Object window, edit the IP address and SNMP port to the new values and click OK.

Step 13: Re-create Topology Discovery Requests

If any discovery requests were manually recorded in Step 2: Record Topology Discovery Requests, 

these requests can now be re-created from the Sun Management Center console.

1. From the main console window, select the appropriate topology domain.

2. Select Tools->Discover Objects to launch the Discover Objects window.

3. From the Discover Objects window, add the desired discovery requests.

Step 14: Verify That the Server Data Was Preserved

Perform the checks described in Chapter 7, Validating the Server Data.
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Chapter 4

Migrating the Server to a Host 
With a Different IP Address

This section describes how to preserve persistent server data when moving a Sun Management 

Center server to a new host system with a different IP address. For the purpose of this discussion, 

the original and new Sun Management Center servers shall be referred to as the source and target 

systems, respectively.

The procedure assumes that the IP addresses of the source and target systems are different. 

The procedure also assumes that the hostname, Sun Management Center software versions, and 

add-ons installed on the source and target systems are the same. The Sun Management Center 

software is assumed to be installed in the same location (/opt/SUNWsymon).

The server host migration procedure is divided into three distinct phases: 

• Back up server data on the source system

• Prepare the server on the target system

• Restore the source data on the target system

The following procedure involves many Sun Management Center software-related tasks. For 

more details on performing these tasks, refer to the Sun Management Center 3.5 User's Guide. For 

more information on installing and configuring Sun Management Center, refer to the Sun 

Management Center 3.5 Installation and Configuration Guide.
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When providing examples of the Sun Management Center software-specific commands to 

be executed (such as/opt/SUNWsymon/sbin/es-start –A), the following procedure 

assumes that the software is installed in the default location (for example, /opt/SUNWsymon). 

If the software is installed in a different location, substitute the appropriate path.

Before starting the procedure, users should back up the server data on the source system 

(employing /opt/SUNWsymon/sbin/es-backup) to ensure that they can restore the Sun 

Management Center server to its current state.

Back Up Server Data on Source System
The Sun Management Center server on the source system is validated, backed up, and stopped 

in this phase of the procedure.

Step 1: Validate the Sun Management Center Server Installation

The Sun Management Center software includes a script to report information about the server 

installation. Information reported by the script includes the installed Sun Management Center 

components, packages, patches, and add-ons. The script also reports the current status of the 

server layer components.

1. Validate the server installation by executing /opt/SUNWsymon/sbin/es-validate 

as root on the source system.

2. Inspect the results to ensure that the server installation is working as expected.

3. Save the results for future reference on the target system.

Step 2: Export the Topology Data

The topology export/import functions can be used to maintain the local topology domains and 

groups because the topology import operation effectively ignores the server IP address embedded 

in the topology domain and group objects.

Note – The topology export function in the initial release of Sun Management Center 3.5 does 

not preserve topology objects that are references to remote topology domains and groups. To pre-

serve these topology objects, they must be manually recorded now so that they can be re-created 

after Step 15: Import the Topology Data. For more details on performing these functions, refer to 

the Sun Management Center 3.5 User's Guide.

To export the local topology data, perform the following steps:

1. Log in to the server using the Sun Management Center console.

2. From the main console window, select Tools->Export Topology to launch the Export Topology 

window.

3. Export “All Domains” to the desired export file. Select the “overwrite” mode to ensure that only 

the current topology data is defined in the export file.

4. The topology export file is saved on the console host.

Step 3: Record Topology Discovery Requests

User-defined discovery requests are associated with topology domains. These discovery requests 

are not included in the topology export data and are not preserved when the topology domains 

are deleted. If the discovery requests need to be preserved, they must be manually noted in this 

step and restored after the topology objects are imported.
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To view the existing discovery requests, perform the following steps from the main console 

window:

1. For each topology domain, select Tools->Discover Objects to launch the Discover Objects window.

2. From the Discover Objects window, select each discovery request to be preserved and manually 

record the Request Details displayed in the lower pane.

Step 4: Delete the Topology Objects

After exporting the topology data, all topology objects on the source Sun Management Center 

server should be deleted to remove topology data that is dependent on the source server’s IP 

address.

To delete the topology objects from the main console window, perform the following steps:

1. Select File->Domain Manager to launch the Domain Manager window.

2. Delete all topology domains.

Step 5: Back Up the Sun Management Center Server Data

After deleting the topology objects, the persistent server data on the source system should be 

backed up using the standard Sun Management Center backup script.

1. Log out from the Sun Management Center console.

2. Back up the server data by executing /opt/SUNWsymon/sbin/es-backup as root on the 

source server host.

Note – The backup script automatically stops server layer processes during the backup.

Step 6: Stop the Sun Management Center Server Layer

After the backup is complete, the backup script automatically restarts the server processes on the 

source system. The server layer must be stopped immediately to ensure that the backed up data is 

synchronized with the agents.

1. Stop the server layer by executing /opt/SUNWsymon/sbin/es-stop –A as root on the 

source system.

Step 7: Transfer Data to the Target Host

The es-validate results generated in Step 1: Validate the Sun Management Center Server and the 

server backup data files generated in Step 5: Back Up the Sun Management Center Server Data 

must be accessible on the target server system. The topology export file generated in Step 2: 

Export the Topology Data must be accessible from the Sun Management Center console host.

1. Copy the es-validate results and server backup data files from the source system to a location 

that can be accessed by the target system.

2. If necessary, copy the topology export file to the console host that will interface with the 

target server.

Step 8: Disconnect or Rename the Source System

The source system is no longer required for the remainder of the procedure.

1. Disconnect or rename the source system so that its hostname does not conflict with the target 

system.
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Prepare the Server on the Target System
This phase involves installing and setting up the Sun Management Center server software on the 

target system.

Step 9: Set Hostname of the Target System

This step involves configuring the target system with the same hostname and a different IP 

address as the source system. The IP address of the target system should also be associated 

with the server hostname on the network host maps (for example, NIS, DNS, and so on).

1. Configure the target system with the hostname of the source system (such as edit /etc/

hosts file). It is assumed that the source and target system IP addresses are different.

2. In the network host maps, change the IP address associated with the server hostname from 

the source system IP address to the target system IP address.

Step 10: Install Sun Management Center Server Software on the Target System

The source and target systems must have the same Sun Management Center version and add-ons 

installed. The Sun Management Center software, add-ons, and patches installed on the source 

system are summarized in the es-validate report that was generated in Step 1: Validate the Sun 

Management Center Server Installation. This step includes installing, setting up, and verifying the 

Sun Management Center server in the target system.

1. On the target system, install the same version of Sun Management Center and add-ons that 

were installed on the source system. This is accomplished by executing the appropriate Sun 

Management Center installation script (for example, es-inst or es-guiinst) from the 

install image.

2. At the end of the install phase, choose to set up the Sun Management Center software. The 

security seed specified during this setup phase is not important because it will be overridden 

later when the data backed up from the source system is restored.

3. At the end of the setup phase, choose to start the server layer.

4. Assuming the server layer started successfully, verify that the Sun Management Center installa-

tion is working by logging in via the Sun Management Center console.

5. After verifying that all is well, log out of the Sun Management Center console and stop the 

server layer.

Step 11: Make a Copy of /etc/system

During installation and setup of the Sun Management Center server, modifications may be made 

to the /etc/system file. As a result, the Sun Management Center backup and restore scripts 

preserve the /etc/system file1. This behavior is not normally an issue when Sun Management 

Center backup data is restored on the same host system. However, when the backup data is 

restored on a different host system (as in this scenario), overwriting the /etc/system file can 

cause problems.

This step backs up the /etc/system file on the target system after Sun Management 

Center is installed and setup, so it can be reinstated after the backup is restored.

1. Copy the /etc/system file on the target system to a safe location.

1. The policy of backing up and restoring the /etc/system file through the Sun Management Center backup and restore 
scripts is under review. Future releases of Sun Management Center may not automatically restore this file.
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Restore Source Data on the Target System
After preparing the target system and backing up the source system, data can be restored on the 

Sun Management Center server on the target system.

Step 12: Restore Backup Data on the Target System

This step restores the data backed up on the source system. 

Note – The restore script automatically shuts down the Sun Management Center server layer 

before restoring the backup, and automatically restarts the server after the restore operation.

1. Log in as root on the target system.

2. Restore the backup data by executing /opt/SUNWsymon/sbin/es-restore as root on 

the target host. When prompted for which backup to restore, specify the appropriate directory 

path from the source system to the backup.

3. When the restore operation is complete, stop the Sun Management Center server layer by 

executing /opt/SUNWsymon/sbin/es-stop –A as root on the target host.

Step 13: Restore /etc/system on the Target System

1. On the target system, restore the /etc/system file that was backed up in Step 11: Make 

a copy of /etc/system.

Step 14: Update the Server IP Interfaces Configuration

The IP interfaces supported by the Sun Management Center server are maintained in a 

configuration file. This configuration can be updated to reflect the new server IP address 

by executing the following commands on the target host as root:

1. Run /opt/SUNWsymon/sbin/esmultiip -l to list the IP addresses supported 

by the Sun Management Center server.

2. Assuming that the list does not contain the desired server IP addresses or contains the old IP 

address, update the server IP interfaces configuration with all IP addresses of active IP inter-

faces as follows:

rm /var/opt/SUNWsymon/cfg/multiip.dat
/opt/SUNWsymon/sbin/esmultiip

3. If necessary, delete unwanted IP addresses from the server IP interface configuration file 

as follows:

/opt/SUNWsymon/sbin/esmultiip -d <IP address>

4. Run /opt/SUNWsymon/sbin/esmultiip -l again to verify that the list of IP addresses 

supported by the Sun Management Center server is correct.

Step 15: Reset Sun Management Center Server Security

Once the server IP address has been changed, the security configuration of the SNMP-based server 

components can be reset. This is accomplished as follows:

1. Execute the following command as root on the server host:

/opt/SUNWsymon/sbin/es-run base-usm-seed.sh -clean –s seed

where seed is the same security seed specified when the server was last set up. When 

prompted on whether to overwrite files, answer yes.
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Step 16: Change Server Agent SNMP Port (Optional)

If the PRM add-on is installed on the server and the Sun Management Center agent on the server 

host collects PRM data, the SNMP port of the server host’s agent must be modified to allow PRM 

to collect and display new PRM data from the server agent.

1. To modify the agent SNMP port, execute the following command as root on the Sun Manage-

ment Center server host:

/opt/SUNWsymon/sbin/es-config -p agent

When prompted for the SNMP port, enter a new unused port number. When prompted for 

a seed, enter the same value specified earlier for the server context.

Step 17: Restart the Sun Management Center Server Layer

1. Restart the server layer by executing /opt/SUNWsymon/sbin/es-start –A as root on 

the server host.

Step 18: Restart All Agents in the Server Context

All the agents in the server context must be restarted to ensure that their security information 

is synchronized with the Sun Management Center server. For each agent in the server context, 

restart the agent process as follows:

1. Log in to the agent host as root.

2. Stop the agent by executing /opt/SUNWsymon/sbin/es-stop –a.

3. Start the agent by executing /opt/SUNWsymon/sbin/es-start –a.

Step 19: Import the Topology Data

To restore the topology domains, groups, and entities from the original configuration, the 

topology export file generated in Step 2: Export the Topology Data must be imported. The 

topology data is an important entry point for accessing agent-specific data such as data 

properties, alarm information, PRM history, and so on.

1. Log in to the server via the Sun Management Center console.

2. Select Tools->Import Topology to launch the Import Topology window.

3. Import the file exported in Step 2: Export the Topology Data using the “follow” mode 

to preserve the original topology domain hierarchy.

Step 20: Modify Server Agent Topology Data

The topology data imported in the previous step is accurate with the exception of topology 

entities that reference Sun Management Center agents running on the server host. These entities 

can include the original agent in the Default Domain, as well as platform agents running on the 

server host.

For each entity to be modified, perform the following steps:

1. From the main console window, select the topology entity to be modified.

2. Right click on the entity and select the “Modify Object” option to launch the Modify Object 

window.

3. In the Modify Object window, edit the IP address to the new value and click OK.
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Step 21: Re-create Topology Discovery Requests

If any discovery requests were manually recorded in Step 3: Record Topology Discovery Requests, 

these requests can now be re-created from the Sun Management Center console.

4. From the main console window, select the appropriate topology domain.

5. Select Tools->Discover Objects to launch the Discover Objects window.

6. From the Discover Objects window, add the desired discovery requests.

Step 22: Verify That the Server Data Was Preserved

1. Validate the Sun Management Center server installation by executing /opt/SUNWsymon/

sbin/es-validate as root on the target server host. Compare the script results with those 

from the source system.

2. Perform the checks listed in Chapter 7, Validating the Server Data.
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Chapter 5

Migrating the Server to a Host 
With a Different Hostname and 
IP Address

This section describes how to preserve persistent server data when moving a Sun Management 

Center server to another host system with a different hostname and IP address. For the purpose 

of this discussion, the original and new Sun Management Center servers are referred to as the 

source and target systems, respectively.

This procedure assumes that the hostnames and IP addresses of the source and target 

systems are different. The procedure also assumes that the Sun Management Center software 

versions and add-ons installed on the source and target systems are the same. The Sun 

Management Center software is assumed to be installed in the same location (for example, 

/opt/SUNWsymon).

The server host migration procedure is divided into three distinct phases: 

• Back up the server data on the source system

• Prepare the server on the target system

• Restore the source data on the target system

The following procedure involves many Sun Management Center software-related tasks.

For details on performing general Sun Management Center tasks, refer to the Sun Management 

Center 3.5 User's Guide. For information on installing and configuring the Sun Management 

Center software, refer to the Sun Management Center 3.5 Installation and Configuration Guide.
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When providing examples of the Sun Management Center software-specific commands to 

be executed (such as /opt/SUNWsymon/sbin/es-start –A), the following procedure 

assumes that the Sun Management Center software is installed in the default location (for 

example, /opt/SUNWsymon). If the software is installed in a different location, substitute 

the appropriate path.

Before starting the procedure, users should back up the Sun Management Center server data 

on the source system (employing /opt/SUNWsymon/sbin/es-backup) to ensure that they 

can restore the server to its original state.

Back Up Server Data on the Source System
The Sun Management Center server on the source system is validated, backed up, and stopped 

in this phase of the procedure.

Step 1: Validate the Sun Management Center Server Installation

The Sun Management Center software includes a script to report information about the server 

installation. Information reported by the script includes the installed Sun Management Center 

components, packages, patches, and add-ons. The script also reports the current status of the 

server layer components.

1. Validate the server installation by executing /opt/SUNWsymon/sbin/es-validate 

as root on the source system.

2. Inspect the results to ensure that the server installation is working as expected.

3. Save the results for future reference on the target system.

Step 2: Export the Topology Data

The topology export/import functions can be used to maintain the local topology domains and 

groups because the topology import operation effectively ignores the server IP address embedded 

in the topology domain and group objects.

Note – The topology export function in the initial release of Sun Management Center 3.5 does 

not preserve topology objects that are references to remote topology domains and groups. To pre-

serve these topology objects, these objects must be manually recorded now so that they can be 

re-created after Step 15: Import the Topology Data. For more details on performing these func-

tions, refer to the Sun Management Center 3.5 User's Guide.

To export the local topology data, perform the following steps:

1. Log in to the server using the Sun Management Center console.

2. From the main console window, select Tools->Export Topology to launch the Export Topology 

window.

3. Export “All Domains” to the desired export file. Select the “overwrite” mode to ensure that only 

the current topology data is defined in the export file.

4. The topology export file is saved on the Sun Management Center console host.
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Step 3: Record Topology Discovery Requests

User-defined discovery requests are associated with topology domains. These discovery requests 

are not included in the topology export data and are not preserved when the topology domains 

are deleted. If discovery requests need to be preserved, they must be manually noted in this step 

and restored after the topology objects are imported.

To view existing discovery requests, perform the following steps from the main console 

window:

1. For each topology domain, select Tools->Discover Objects to launch the Discover Objects window.

2. From the Discover Objects window, select each discovery request to be preserved, and manually 

record the Request Details displayed in the lower pane.

Step 4: Delete the Topology Objects

After exporting the topology data, all topology objects on the source Sun Management Center 

server should be deleted to remove topology data that is dependent on the source server’s IP 

address.

To delete topology objects from the main Sun Management Center console, perform the 

following steps:

1. Select File->Domain Manager to launch the Domain Manager window.

2. Delete all topology domains.

Step 5: Back Up Sun Management Center Server Data

After deleting topology objects, the persistent server data on the source system should be backed 

up using the standard Sun Management Center backup script.

1. Log out from the Sun Management Center console.

2. Back up the server data by executing /opt/SUNWsymon/sbin/es-backup as root on the 

source server host. 

Note – The backup script automatically stops the server layer processes during the backup.

Step 6: Stop the Sun Management Center Server Layer

After the backup is complete, the backup script automatically restarts the Sun Management 

Center server on the source system. The server layer must be stopped immediately to ensure 

that the backed up data is synchronized with the agents.

1. Stop the server layer by executing /opt/SUNWsymon/sbin/es-stop –A as root on the 

source system.

Step 7: Transfer Data to the Target Host

The es-validate results generated in Step 1: Validate the Sun Management Center Server and the 

server backup data files generated in Step 5: Back Up the Sun Management Center Server Data 

must be accessible on the target server system. The topology export file generated in Step 2: 

Export the Topology Data must be accessible from the Sun Management Center console host.

1. Copy the es-validate results and server backup data files from the source system to a location 

that can be accessed by the target system.

2. If necessary, copy the topology export file to the Sun Management Center console host that will 

interface with the target server.
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Prepare the Server on the Target System
This phase involves installing and setting up Sun Management Center server software on the 

target system.

Step 8: Install Sun Management Center Server Software on the Target System

The source and target systems must have the same Sun Management Center version and add-ons 

installed. The software, add-ons, and patches installed on the source system are summarized in 

the es-validate report that was generated in Step 1: Validate the Sun Management Center Server 

Installation. This step includes installing, setting up, and verifying the Sun Management Center 

server in the target system.

1. On the target system, install the same version of Sun Management Center and add-ons that 

were installed on the source system. This is accomplished by executing the appropriate Sun 

Management Center installation script (for example, es-inst or es-guiinst) from the 

install image.

2. At the end of the install phase, choose to set up the Sun Management Center software. The 

security seed specified during this setup phase is not important because it will be overridden 

later when the data backed up from the source system is restored.

3. At the end of the setup phase, choose to start the server layer.

4. Assuming the Sun Management Center server layer started successfully, verify that the server 

installation is working by logging in via the Sun Management Center console.

5. After verifying that all is well, log out of the Sun Management Center console and stop the 

server layer.

Step 9: Make a Copy of /etc/system and Selected Files

During installation and setup of the Sun Management Center server, modifications may be made 

to the /etc/system file. As a result, the Sun Management Center backup and restore scripts 

preserve the /etc/system file.2

This behavior is not normally an issue when the Sun Management Center backup data is 

restored on the same host system. However, when the backup data is restored on a different 

host system (as in this scenario), overwriting the /etc/system file can cause problems.

This step backs up the /etc/system and various Sun Management Center configuration 

files on the target system after Sun Management Center is installed and set up, so they can be 

reinstated after the backup is restored.

1. Copy the /etc/system file on the target system to a safe location.

2. Copy the following Sun Management Center configuration files on the target system to a safe 

location:

/var/opt/SUNWsymon/cfg/domain-config.x

/var/opt/SUNWsymon/cfg/dbase.cfg

/var/opt/SUNWsymon/cfg/multiip.dat

/var/opt/SUNWsymon/PRM/agent/data/file_record.dat3

2. The policy of backing up and restoring the /etc/system file through the Sun Management Center backup and restore 
scripts is under review. Future releases of Sun Management Center may not automatically restore this file.

3. The file_record.dat file is present only if PRM is installed. If PRM is not installed, this file does not need to be 
backed up.



P22  Sun™ Management Center 3.5 Server Data Migration © 2003 Sun Microsystems, Inc.

Restore Source Data on the Target System
After preparing the target system and backing up the source system, data can be restored on the 

Sun Management Center server on the target system.

Step 10: Restore Backup Data on the Target System

This step restores the data backed up on the source system.

Note – The restore script automatically shuts down the Sun Management Center server layer 

before restoring the backup, and automatically restarts the server after the restore operation.

1. Log in as root on the target system.

2. Manually edit hostname value in the backup meta file (Sun Management Center_BAK.meta) 

that is part of the Sun Management Center backup from the source system. Change the HOST-

NAME value from the source system hostname to the target system hostname.

3. Restore the backup data by executing /opt/SUNWsymon/sbin/es-restore as root on 

the target host. When prompted for which backup to restore, specify the appropriate directory 

path from the source system to the backup.

4. When the restore operation is complete, es-restore automatically attempts to restart the server 

layer. Not all processes will start successfully.

5. Ensure that all Sun Management Center server processes are not running by executing /opt/

SUNWsymon/sbin/es-stop –A as root on the target host.

Step 11: Restore /etc/system and Selected Files on the Target System

1. On the target system, restore the /etc/system and other Sun Management Center files that 

were backed up in Step 9: Make a Copy of /etc/system and Selected Sun Management Center Files.

Step 12: Reset Sun Management Center Server Security

The security configuration of the SNMP-based server components must be reset to reflect the IP 

address of the server. This is accomplished as follows:

1. Execute the following command as root on the Sun Management Center server host: 

/opt/SUNWsymon/sbin/es-run base-usm-seed.sh -clean –s seed

where seed is the same security seed specified when the source server was last set up. 

When prompted to overwrite files, answer yes.

Step 13: Restart the Server Layer

1. Restart the server layer by executing /opt/SUNWsymon/sbin/es-start –A as root on 

the server host.

Step 14: Reconfigure All Agents in the Server Context

All the agents in the server context must be reconfigured with the new Sun Management Center 

server hostname and then restarted to ensure that their security information is synchronized with 

the server.

For each agent in the server context, perform the following steps:

1. Log in to the agent host as root.

2. Stop the agent by executing /opt/SUNWsymon/sbin/es-stop –a.
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Reconfigure the agent's server context by executing /opt/SUNWsymon/sbin/es-setup -F 

and specify the target server’s hostname as the server context. When prompted for the security 

seed, enter the same value specified for the server in Step 12: Reset Sun Management Center 

Server Security.

3. Start the agent by executing /opt/SUNWsymon/sbin/es-start –a.

Step 15: Import the Topology Data

To restore topology domains, groups, and entities from the original configuration, the topology 

export file generated in Step 2: Export the Topology Data must be imported. The topology data 

is an important entry point for accessing agent-specific data such as data properties, alarm 

information, PRM history, and so on.

1. Log in to the server via the Sun Management Center console.

2. Select Tools->Import Topology to launch the Import Topology window.

3. Import the file exported in Step 2: Export the Topology Data using the “follow” mode 

to preserve the original topology domain hierarchy.

Step 16: Update Server Agent Topology Data

The topology data imported in the previous step is accurate, with the possible exception of topology 

entities that reference agents running on the source server system. These entities can include the 

original agent in the Default Domain, as well as platform agents running on the server host.

From the main console window, perform the following steps:

1. Delete undesired topology objects referencing entities from the source system.

2. Create new topology objects associated with the target system.

Step 17: Re-create Topology Discovery Requests

If discovery requests were manually recorded in Step 3: Record Topology Discovery Requests, 

these requests can now be re-created from the Sun Management Center console.

1. From the main console window, select the appropriate topology domain.

2. Select Tools->Discover Objects to launch the Discover Objects window.

3. From the Discover Objects window, add the desired discovery requests.

Step 18: Verify That the Server Data Was Preserved

1. Validate the Sun Management Center server installation by executing /opt/SUNWsymon/

sbin/es-validate as root on the target server host. Compare the script results with those 

from the source system.

2. Perform the checks listed in the section entitled Validating the Server Data.
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Chapter 6

Reconfiguring PRM on the Server

The following procedure describes how to change the size and locations of PRM-specific data 

files on the Sun Management Center 3.5 server layer. This procedure assumes that the new PRM 

configuration size is the same or larger than the one specified in the previous setup (for example, 

small to small, medium, or large; medium to medium or large; and large to large). This is necessary 

to ensure that the new installation has sufficient space to accommodate the existing PRM data. 

The procedure also assumes that the same version of PRM (3.5) is reinstalled on the server.

The procedure involves several Sun Management Center and PRM-related tasks. For more 

details on performing these tasks, refer to the Sun Management Center 3.5 User's Guide and 

the Sun Management Center 3.5 Performance Reporting Manager User's Guide.

It is recommended that the procedure be completed in one session to minimize the 

downtime of the Sun Management Center server and PRM.

Note – When providing examples of the Sun Management Center software-specific commands 

to be executed (such as /opt/SUNWsymon/sbin/es-backup), the following procedure 

assumes that the software is installed in the default location (for example, /opt/SUNWsymon). 

If the software is installed in a different location, substitute the appropriate path.

Step 1: Back Up the Sun Management Center Server Data

This step backs up persistent Sun Management Center server data. This data includes both core 

data as well as PRM-specific data.

The backup script automatically shuts down the server layer if it is running. At the end of the 

backup, the script automatically restarts the server layer.
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1. To back up the persistent server data, execute /opt/SUNWsymon/sbin/es-backup -e 

as root on the Sun Management Center server host. The -e option must be specified to ensure 

that the backup data format is compatible with this procedure.

Step 2: Uninstall the PRM Add-on on the Server

This step uninstalls the PRM add-on on the server layer host only. PRM should not be uninstalled 

on the agent hosts.

1. Uninstall the PRM add-on by executing /opt/SUNWsymon/es-uninst as root on the server 

layer host.

2. Choose to uninstall PRM only and do NOT keep the PRM data.

Step 3: Reinstall and Set Up PRM

After uninstalling PRM, install and set up PRM with the desired configuration.

1. To install PRM, execute /opt/SUNWsymon/sbin/es-inst as root on the server host.

2. Choose to install PRM only.

3. Choose to continue with the setup and specify the desired PRM configuration size (small, 

medium, or large) and locations. The new PRM configuration size must be the same or larger 

than the one specified in the previous setup. The PRM locations can be new or the same directo-

ries as before.

4. Decline to restart the Sun Management Center server at the end of the setup.

Step 4: Back Up the prm-dbase.cfg File

The PRM configuration file (prm-dbase.cfg) specifies the PRM configuration size. This file 

is overwritten when the backup is restored. To ensure that it is retained, back it up.

1. Copy /var/opt/SUNWsymon/cfg/prm-dbase.cfg to a safe location. 

Step 5: Restore the Sun Management Center Server Backup

1. Restore the backup created in Step 1 by executing /opt/SUNWsymon/sbin/es-restore 

as root on the server.

2. At the end of the restore operation, the script restarts the server layer.

Step 6: Restore the prm-dbase.cfg File

1. Stop the Sun Management Center server layer by executing /opt/SUNWsymon/sbin/es-

stop –A as root on the server host.

2. Restore the prm-dbase.cfg file backed up in Step 4: Back Up the prm-dbase.cfg File by copy-

ing it to /var/opt/SUNWsymon/cfg/prm-dbase.cfg

3. Start the server layer by executing /opt/SUNWsymon/sbin/es-start –A as root on the 

server host.
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 Step 7: Verify That Sun Management Center and PRM Are Working

1. Log in using the Sun Management Center console and verify that the topology domains, 

groups, and entities are as before.

2. From the Sun Management Center console, generate PRM reports to view historical PRM data.

3. After a few hours, inspect the PRM Data Collection window to verify that PRM data continues 

to be collected from the agents.
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Chapter 7

Validating the Server Data

This section describes several checks to verify that the server data migration procedure 

was successful. Known limitations of these procedures are also discussed.

Server Data Validation
After completing the procedures that involve changing the server IP address or moving the Sun 

Management Center server to another system, it is recommended that the following checks be 

performed to verify that the server data was preserved.

1. Log in using the Sun Management Center console and verify that the topology domains, 

groups, and entities in the original installation are retained in the new installation.

2. Ensure that the status of the topology objects is as expected (there is no unexpected alarm 

such as indeterminate status).

3. Launch one or more Host Detail windows to browse data from Sun Management Center agents 

to verify that communication can be established.

4. From one or more Host Detail windows, verify that the agent’s security configuration is valid by 

temporarily loading and unloading modules, editing property attributes such as alarm thresholds, 

and so on.

Note – These privileged actions must be performed as a Sun Management Center user with the 

appropriate security privileges.
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5. Verify that the alarm information for agents is still available by inspecting the Alarms tab on 

one or more Host Details windows.

6. If the PRM add-on is installed, verify that the PRM reports, templates, scheduled jobs, and his-

torical data were retained. After a few hours, inspect the Data Collection window to verify that 

the PRM data continues to be collected from the agents.

Known Limitations
The hostname and IP address change-specific procedures have limitations related to preserving 

references to remote topology domains and groups, as well as accessing old PRM data for the 

agent running on the server host.

References to Remote Topology Domains and Groups

Sun Management Center supports the ability to reference topology domains and groups from 

remote server contexts. The topology export operation in the initial product release of Sun 

Management Center 3.5 does not preserve references to remote domains and groups. Consequently, 

references that must be preserved to remote topology domains and groups must be manually 

noted from the source server installation, and re-created in the target installation.

For more details on inspecting and creating topology objects that reference remote domains 

and groups, please refer to the Sun Management Center 3.5 User's Guide.

Note – This limitation of the topology export function in Sun Management Center 3.5 is cur-

rently under review. Future updates or releases of Sun Management Center may support the 

ability to export and import references to remote topology domains and groups.

Accessing PRM Data for the Agent on the Server Host

When the PRM add-on is installed, the agent on the server layer host is automatically configured 

to track performance data. This performance data is stored in the Sun Management Center server 

layer.

In a scenario where the server IP address is changed but the server hostname is not changed, 

migration procedures described in this document instruct users to change the SNMP port of the 

agent on the server host. By following these procedures, new performance data collected from 

the agent after the migration process can be accessed through the Sun Management Center Java 

technology-based GUI. However, old performance data for the agent cannot be retrieved from the 

Sun Management Center GUI.
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Chapter 8

Summary

The server layer is the heart of the Sun Management Center application and maintains persistent 

data critical to the product’s overall operation. Persistent data is sensitive to changes in the 

server's hostname and primary IP address. Persistent data of add-ons, such as PRM, is also 

affected by changes to the configuration of PRM data files.

This document describes procedures that enables users to migrate their Sun Management 

Center 3.5 server data when they change the hostnames and primary IP addresses of their server 

hosts. The procedures cover cases where the Sun Management Center server installation stays on 

the same system or is moved to another host system.

This document also includes the procedure to preserve existing PRM 3.5 server data when 

changing PRM configuration size and locations of the PRM data files. These procedures assume 

that the Sun Management Center software versions and installed add-on packages are unchanged. 

Since these procedures have been tested in only a limited set of cases, users should validate server 

data after completing documented procedures.
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